Still cannot rip 3:10 To Yuma with Handbrake

Discussion in 'Apple TV and Home Theater' started by ttx336, Nov 22, 2012.

  1. ttx336 macrumors newbie

    May 29, 2011
    This thing seems to be invincible... I have followed numerous suggestions about choosing specific titles, using the Open Specific (something like that), etc. I went to DVD player to see which title is playing during the actual movie playback, it shows title 1 but that doesn't work in ripping. I have gone to the effort of trying each and every one of the titles to no avail, even typing in the ones that do not show up when I let Handbrake scan for sources.

    I'm running 0.9.8 64 bit - this is the first time Handbrake has ever failed me, it is truly a great program!
  2. mic j macrumors 68030

    Mar 15, 2012
    Have you tried ripping with MakeMKV then transcoding with HB?
  3. ttx336 thread starter macrumors newbie

    May 29, 2011
    I have not, I am trying to keep the amount of software that I add to this machine at a minimum, I followed some advice on the Handbrake forum to try the latest nightly build and that did the trick.
  4. dukebound85 macrumors P6


    Jul 17, 2005
    5045 feet above sea level
    Haha I know! I just keep it as a large DVD image in my library when everything else has been converted to a mp4
  5. brand, Nov 23, 2012
    Last edited: Nov 24, 2012

    brand macrumors 601


    Oct 3, 2006
    So remove it when you are done with it. I don't see what the problem is.

    MakeMKV does not create an image of the DVD, it just rips the content that you want from the disc. An image of the disc is something else entirely.
  6. ZmyDust macrumors regular


    Feb 20, 2011
    Sure makemkv might work, but Handbrake for me, since I learned the Open Source Title trick ha been incredibly reliable. So why doesn't it work? Let's problem solve rather than take another full step.

    I'm having this same problem with not only 3:10 to Yuma, but also the movie "21". One thing to note is that both of the movies start with a number, and both come up not simply as 21 but <21> when the disc is entered. Could it be the brackets holding it back? Any ideas on why this would happen?

    I tried to take out the brackets on the destination file and still it doesnt rip right. For me it rips a 4kb file with 0:00 running time of video and only takes about a second before it says the rip is complete.
  7. dynaflash macrumors 68020

    Mar 27, 2003
    ... as the OP said, the nightly build of HB worked.
  8. ThisOneHere macrumors newbie

    Feb 12, 2008
    Upstate, NY
    I converted both 3:10 to Yuma and 21 without issue using MakeMKV then Handbrake. If you're having issues using Handbrake directly, try the nightly build as previously suggested, but if that doesn't work, just use MakeMKV. All it does is rip the portion of the full disc you want (such as video, selected audio and subtitles). It takes about 20-25 minutes to rip using MakeMKV. It's freeware, only a few MBs, and can be easily removed afterwards. You answered your own question about brackets, since removing them didn't help. I think it's an issue with that version of Handbrake and the disc encryption type (or version of encryption) used in those movies. MakeMKV would remove that encryption, which is why that works fine.

    Seems more efficient to do that and get it over with and move on with life than to waste days waiting for someone to tell you why Handbrake couldn't do it directly... Just my opinion (speaking from experience with those movies). Good luck!

Share This Page