Still cant get playlist to sync?

ki2594

macrumors 6502a
Original poster
Apr 12, 2008
802
5
Carmel, IN.
I've tried all the tips I've seen from people having issues syncing music to their watch but I still cant seem to get it to get past "Sync pending". I've tried both devices on the charger/just the apple watch on the charger/trying different playlists etc.

Any other tips? Really would love to use this thing in the gym without my phone.
 

CobraPA

macrumors 6502a
Mar 12, 2011
726
173
Lansdale, PA, USA
You have bluetooth turned on? (I assume so, but you don't mention it in this post.)

It takes a long time, you probably need to leave it overnight. If it loses connection at all, it will restart the transfer. Hopefully they're going to improve this (a lot.)

So... watch on charger. Phone in bluetooth range. Leave for an hour, maybe more.
 

ki2594

macrumors 6502a
Original poster
Apr 12, 2008
802
5
Carmel, IN.
You have bluetooth turned on? (I assume so, but you don't mention it in this post.)

It takes a long time, you probably need to leave it overnight. If it loses connection at all, it will restart the transfer. Hopefully they're going to improve this (a lot.)

So... watch on charger. Phone in bluetooth range. Leave for an hour, maybe more.
Yeah I've tried it multiple nights. Unfortunately it never starts.
 

ckurt25

macrumors 6502a
Mar 25, 2009
997
345
Grand Rapids, MI
How big is the playlist? I wonder if size has anything to do with it. You may want to try rebooting the phone and watch to see if that helps.
 

ki2594

macrumors 6502a
Original poster
Apr 12, 2008
802
5
Carmel, IN.
How big is the playlist? I wonder if size has anything to do with it. You may want to try rebooting the phone and watch to see if that helps.
I've tried different ones just to see if any would work because I too figured maybe my Recently Played list would be too big. So then I tried Recently Added, which was only like 30 normal length songs to no avail.
 

ckurt25

macrumors 6502a
Mar 25, 2009
997
345
Grand Rapids, MI
Wish I could be of more help.

One thing I ran into this morning trying to use my watch at the gym this morning that might be good to pass along is changing the source for the music. I incorrectly assumed that when my phone was out of range that the sync'd playlist would automatically come up when I was in the music app. It did not. I only fooled around with it for a minute or so then just started my workout. Once you do get a playlist on your watch, and you have bluetooth headphones (or speakers) to play the music through, you need to use force touch from the music app (not from now playing) and select the source (watch / phone). Once you select the watch it'll make an attempt to connect / play through your headphones. By the time I figured this out I was already at work and didn't have my BT headphones with me to make sure it worked without a hitch but I think that's the process.
 
  • Like
Reactions: specialk0449

ki2594

macrumors 6502a
Original poster
Apr 12, 2008
802
5
Carmel, IN.
Have you set a Playlist size limit in the Music app settings in the Watch app?
yeah to no avail either :/ kind of frustrating as I have bluetooth headphones and go to the gym often. It's one of my favorite features that I was looking forward to
 

JPGR_Fan

macrumors regular
Apr 5, 2003
188
29
St. Louis
Had to unpair Watch and iPhone to get out of sync pending purgatory

After much effort on my own, I finally called Apple Care. Guy was very good, and went right with doing an unpair of the iPhone and Apple Watch, and then a re-pair. It takes time at each step, maybe especially the music part, but all those electrons must be placed in the exact right position :).
 

ki2594

macrumors 6502a
Original poster
Apr 12, 2008
802
5
Carmel, IN.
Wow that is what it took. Kind of annoying but went through the repairing process and now it's syncing. I DID restore from back up for anyone that stumbles upon this and wonders if they need to do a fresh repair or not.
 

Similar threads

  • ssledoux
3
Replies
3
Views
380
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.