Still Get Kernel Panics

Discussion in 'OS X El Capitan (10.11)' started by jeyf, Aug 8, 2015.

  1. jeyf macrumors 6502

    Joined:
    Jan 20, 2009
    #1
    just fyi
    mid 2010 vintage macbook pro with 10.11 public beta 1,2,3,4

    "sandbox unable to determine protected devices"...

    running VLC & Safari
     
  2. ShadovvMoon macrumors 6502

    ShadovvMoon

    Joined:
    May 22, 2015
    Location:
    Brisbane, Queensland, Australia
    #2
    I had 6 kernel panics today. I didn't have any problems with betas 1 to 4, but 5 is panicking like crazy :(
     
  3. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #3
    I had lots of these "Sandbox unable to determine protected devices" panics in betas 1 -3 but i've not had any yet in PB4 — try turning OFF rootless and I suspect you'll not see these kernel panics...

    Oh, do report these using feedback assistant / bugs!!!
     
  4. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
    #4
    I haven't had a single one of those or panics on my 2015 13" rMBP. how old was your install before you upgraded? I formatted mine before upgrading to avoid any old lingering software or weird configs being migrated over.
     
  5. jeyf, Aug 9, 2015
    Last edited: Aug 10, 2015

    jeyf thread starter macrumors 6502

    Joined:
    Jan 20, 2009
    #5
    recall:
    i did a clean wipe install of Yosemite 10.10.4
    i had the local apple store run over night hardware diagnostics
    than i installed the public beta 4

    i disabled System Integrity (rootless); but still get the kernel panics as before
    there are a couple of methods floating around
    1) system reset with control + command + p + r
    in the OSX Utilities screen public beta 4
    Utilities->Security Config
    uncheck the box
    assert the bottom apply configuration
    2) sudo nvram boot-args="rootless=0";sudo reboot

    either method i did not observe a change
    also
    the Disk Utility "info" screen displays the system integrity status
    which indicated that rootless still active
     
  6. nontroppo macrumors 6502

    nontroppo

    Joined:
    Mar 11, 2009
    #6
    Yes, the boot-args method is not working in PB4 — you need to reboot into recovery partition and disable rootless there using the GUI. From the panic logs I got:

    *** Panic Report ***
    panic(cpu 3 caller 0xffffff7f968ed4ed): "Sandbox unable to determine protected devices"@/BuildRoot/Library/Caches/com.apple.xbs/Sources/Sandbox_executables/Sandbox-442.0.0.1.3/src/kext/iokit_rootless.cpp:415

    It appeared to have something to do with rootless, and since i've disabled it I haven't had crashes (although it may also be the fact I upgraded to PB4)...
     
  7. jeyf, Aug 12, 2015
    Last edited: Aug 12, 2015

    jeyf thread starter macrumors 6502

    Joined:
    Jan 20, 2009
    #7
    I am not sure even rebooting into recovery changes the rootless status

    the new El Capitan info screen has a "system integrity protection enabled" status
    it dosnt change much so something or other is busted



    maybe i got it to disable sometime yesterday as i noticed the new crop of kernel panics have nothing to with the sandBox status. They are from various applications.

    considering the kernel panics started in Yosemite with this machine (mid 2010 macbook pro) and they continue to happen with El Capitan public beta4 little chance for a resolve going up in revision. Especially since ElCapitan getting released September/October

    oh well... fall back to 10.9 for stable operation
     

Share This Page