still getting disk not ejected properly errors

Discussion in 'OS X El Capitan (10.11)' started by Potatochobit, Jul 10, 2016.

  1. Potatochobit macrumors regular

    Joined:
    Apr 2, 2011
    #1
    ever since upgrading to el capitan
    I keep getting errors, disk not ejected properly over USB 3.0
    this has been going on since last year

    I have 2 hard drives in Software RAID (created by OSX mavericks)
    in a 4 slot JBOD box

    and another 2 same as above in RAID for timemachine in the same 4 slot JBOD box

    I have disabled sleep mode, power mode, etc.
    I have tried to repair, rebuild the hard drives in utilities
    sometimes it will say disk not ejected properly and sometimes it will get a kernel error, and a black screen and need to reboot

    I just dont know what the problem is
    is it the crap mac software? everything was fine in mavericks and yosemite
    is it the JBOD box? cheap USB 3.0?
    is it because I am using mac software RAID? which was removed from el capitan but is in previous OSX
    is it a compatiblity issue with the USB 3.0 HUB (which is plugged into the other side of the mac and only has a mouse and keyboard)

    I just dont know where to keep going with diagnosing this issue
     
  2. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #2
    What make and model?

    If there was another topic, please provide a link.
     
  3. Potatochobit thread starter macrumors regular

    Joined:
    Apr 2, 2011
    #3
  4. C. Alan macrumors 6502

    Joined:
    Jan 23, 2009
    #4
    I have the same problem with my 2009 Mac Pro running El Capitan. However, it is not a new problem for me, as I had the same problem under Mavericks (I skipped Yosemite). For me, It is my USB 3.0 card, and the attached external HD I use for time machine. I have never found a work around for the problem, and I have to reboot about once every three days because it sometimes leads to Finder hanging.
     

Share This Page