Still Getting Error 0xE800002E With 2.1!!

Discussion in 'iPod touch' started by iisarenotnobody, Sep 9, 2008.

  1. iisarenotnobody macrumors member

    Joined:
    Jul 18, 2008
    #1
    I download and install 2.1 in an effort to see if the error of Updating apps with Error 0xE800002E is gone. Turns out its not. It doesnt work on either my iPod or my Mac. What can i do?? I DO NOT want to remove/ install apps all the time!
     
  2. trojanmike34 macrumors newbie

    Joined:
    Oct 16, 2007
    #2
    I still get the same error as well when attempting to update apps via the Touch or iTunes on my mac.
     
  3. siksik6 macrumors member

    Joined:
    Aug 31, 2008
    #3
    So do I... updating apps has never worked for me properly.

    I've always have to delete the app from my phone, update on my Mac then re-sync, and sometimes even that doesn't work.

    Was really hoping 2.1 would have fixed this... it's fixed a lot of other stuff though :)
     
  4. ErikAndre macrumors 6502a

    ErikAndre

    Joined:
    Nov 14, 2007
    Location:
    Florida
    #4
    This was the one issue I was hoping Apple would address in the 2.1 update. How unfortunate.
     
  5. mark10197 macrumors member

    Joined:
    May 31, 2008
    #5
    Restart your computer. If that doesn't worl you need to restore.
    Hope it helps. ;]
     
  6. musketball macrumors newbie

    Joined:
    Sep 13, 2008
    #6
    That's way overkill, no need for this..

    (Set iTunes to sync selected applications)

    Uncheck the offending apps in iTunes and Sync, then check those apps and sync again.
     
  7. ErikAndre macrumors 6502a

    ErikAndre

    Joined:
    Nov 14, 2007
    Location:
    Florida
    #7
    RESOLVED.

    I had this problem for weeks... even after doing two restores. I then followed these instructions shortly after the 2.1 update and the problem has disappeared! I lost all my data on the phone, but it was well worth it than to see that error message for every app. :D
     
  8. Polska macrumors member

    Joined:
    Mar 9, 2008
    Location:
    Rio de Janeiro - RJ
    #8
    Will I lose all the data from the App?

    The problem with that is all data will be lost, right? One of my Apps that is giving me this problem is Aurora Feint, which I am in a very advanced level. I did not wish to start all over again. :(

    Erick
     
  9. hulabaloo macrumors newbie

    Joined:
    Dec 7, 2008
    #9
    new real fix WITHOUT losing data or re-booting!!!

    I just added this to another forum in a thread about this same error. If you have a jailbroken iPhone or iPod Touch at firmware 2.2, this will likely work for you. Hints inside may help with other jailbroken firmware versions.
    =====

    Okay, I'm a bit excited here, but trying not to get ahead of myself. I had this same error on an update to one of my cracked apps that I had double-clicked into iTunes. Then I got notified of updates to several of my free apps, and each of them also would not install the update with the same error.

    Yes, the workaround mentioned in a Google search, of unchecking the app from your Applications list, syncing, re-checking and syncing again, does work, with the well-known and obvious side-effect of losing all the data for that app. So instead, I was going to set aside a few hours tomorrow to follow nlsmiley's steps above. Really, if you think back to the first 2.0 jailbreaks, the instructions always said to download a free app before any cracked ones. Hey, back then there weren't that many cracked ones yet, so this was easy to remember and do. So these instructions made a lot of sense, and I expected them to solve my problem.

    Just for grins, though, I installed "2.2 MobileInstallation Patch" from Cydia (in Steffwiz's repo). It noted that I had apparently already patched the MobileInstallation file, as I had, since I installed it during my 2.2 jailbreak, then it said something about overwriting it anyway? Little type, hard to see, but whatever. I then "bought" a free app (the fabulous new Crossbones) and downloaded and installed it with a regular sync. The sync process proceeded to try to install the up-to-then failed updates (both free and for my cracked app), and seemed to be taking longer to do so. Ya know, kinda like it was really doing it this time! Lo and behold, after the sync finished, NO ERRORS! Just to be sure I turned right around and sync'd again, and it did not try to install anything. My apps are all updated! Woo-hoo!

    EDIT: NO REBOOT INVOLVED! My son's iPod Touch at 2.2 had, like mine, been throwing these same errors as updates accumulated lately. We just did the same procedure with his, and it worked again. I have to wonder if just SFTP'ing into the Touch, and copying the cracked MobileInstallation file over the old one again, followed by the free app first process, would work as well. But that's for others with more time on their hands than me to try. Does the Patch installation process work any other magic inside the Touch that a simply overwrite of the file would not?

    Now hey, it's just one guy here, and who knows if it's permanent, but my apps ARE updated and I did NOT lose my data doing it. Try it and report back here if it works for you too...

    Hopefully this little discovery will run true, and save a bunch of us a bunch of pain. I DO know that from now on I am installing a free app FIRST, EVERY time I upgrade to a new jailbroken firmware version!
     

Share This Page