Still having duplicate messages problem

Discussion in 'iPhone' started by akimoriRyuuji, Feb 5, 2016.

  1. akimoriRyuuji macrumors regular

    akimoriRyuuji

    Joined:
    Jun 28, 2015
    #1
    So, basically...
    I go on the bus, and since I don't have a data plan (yet), I am stuck with plain text messages. So go to send a message and then iMessages starts sending... and then it stops. Because duh, you can't send an iMessage without internet.

    That behaviour, by the way, is quite annoying. Why wouldn't it default to sending as text message if you don't have internet?!

    But anyways, so I long-press and send as text message. Dumb that I have to do that. Even if I do manually send it however, it waits for 5 minutes before telling me 'sending the message failed...' No duh, if you tried to send as an iMessage.

    Well, apparently even if I send the message it'll attempt to send it as an iMessage anyways. So I suspect that's why, that when I send a message and the 5 minutes are up and I get to school and connect to wifi, suddenly it'll send it... again.

    And this isn't just on my end. I receive my friend's messages (who has an iPhone 6s) twice on occasion.

    So you'd say, then if you don't have a persistent internet connection, why don't you just turn off iMessages? And then lose the ability to text from my macbook? No thanks.

    Is there no way to fix this?
     
  2. iDuel, Feb 6, 2016
    Last edited: Feb 6, 2016

    iDuel macrumors 6502a

    iDuel

    Joined:
    Jul 20, 2011
    Location:
    Greece/USA
    #2
    When you are in an area that doesn't have Wi-Fi, just toggle iMessage off and your phone will just default to sending everything as SMS only. When you have Wi-Fi available, just flip iMessage on and you will receive any iMessages sent to you since you turned it off.

    There's really no other way to go about this. iMessage is designed to rely on a constant mobile data/Wi-Fi connection. I think if you turn iMessage off on your phone, you can still use it on your Mac to some extent.
    Also, I loved Blue Exorcist...great show.
     
  3. akimoriRyuuji thread starter macrumors regular

    akimoriRyuuji

    Joined:
    Jun 28, 2015
    #3
    No, iMessage is required to use message forwarding.
    And no, that's not an ideal solution :/ Thanks anyways, though.

    I think I need to raise this seemingly common sense issue up with Apple. Not that they'll fix it. I doubt anyone in Cupertino has ever turned off their unlimited data plans anyways.
     

Share This Page