Still having issues downloading iOS 8

Discussion in 'iOS 8' started by bluechipBMW, Sep 20, 2014.

  1. bluechipBMW, Sep 20, 2014
    Last edited: Sep 20, 2014

    bluechipBMW macrumors member

    Joined:
    Feb 12, 2008
    #1
    I have not been able to download iOS 8. Every time I try with iTunes it says over 20 hours remaining and some times I get over 50 minutes remaining!? I confirmed my internet connection is fine so I then tried OTA and I'm still having issues. When I try OTA I end up getting a message saying "Software failed - An error occurred downloading iOS 8.0.

    I highly doubt the servers are still backed up. Can there be something wrong with my 5S (7.1.2)? I also confirmed I have over 9 gigs of space available. I even tried a manual restore (home and sleep) but no luck.

    Any advise I would greatly appreciate.

    Thanks!!!
     
  2. Sixto macrumors member

    Joined:
    Apr 19, 2011
  3. BasicGreatGuy Contributor

    BasicGreatGuy

    Joined:
    Sep 21, 2012
    Location:
    In the middle of several books.
    #3
    You can download the file from their server, without having to go through iTunes.
     
  4. antiprotest macrumors 65816

    antiprotest

    Joined:
    Apr 19, 2010
    #4
    I think it might still be their server. I was able to download it on Wednesday on my iPhone but could not download on my iPad until last night.

    Keep trying.
     
  5. LostSoul80 macrumors 68020

    LostSoul80

    Joined:
    Jan 25, 2009
    #5
    Your phone has nothing to do with iTunes' downloads, so your connection to Apple servers is probably the only responsible.
    Try downloading your ipsw from here:
    http://www.evad3rs.net/2013/07/ios-8-download-links-for-iphone-ipad.html

    The links point at Apple's servers, probably the same that iTunes uses.
     
  6. Mr.C macrumors 601

    Joined:
    Apr 3, 2011
    Location:
    London, UK.
    #6
    I had a similar problem yesterday on my iPad Air. It said estimated time would be like 13 hours. I stopped the download and tried again two more times with the same result. Them I reset my router and it downloaded in about 6 minutes.
     
  7. evotoiphone macrumors regular

    Joined:
    Oct 7, 2011
    Location:
    Mass
    #7
    Good to know that I am not the only one having this issue!! I have been trying to update for days and when I tried the manual download (3 times) it says it wasn't compatible with my phone even thought the model #'s matched. Uggghhhh
     

Share This Page