Still Having WiFi Trouble on 3.0?

Discussion in 'iPhone' started by Demosthenes X, Aug 4, 2009.

  1. Demosthenes X macrumors 68000

    Demosthenes X

    Joined:
    Oct 21, 2008
    #1
    It seems like I've been having nothing but problems with my iPhone lately, and I'm getting very frustrated with the thing as a result. First my 3.0.1 upgrade failed, and forced me to a complete restore. Then my tethering died, requiring me to downgrade back to 3.0, and now, tonight, my WiFi suddenly stopped working. It no longer even sees ANY WiFi networks - my MacBook sees six - and even if I type in the network name manually it cannot find it. It doesn't matter how I set the network security, the iPhone simply cannot see it.

    What I've done:
    1) Tried turning the phone off and on again. It saw the network and connected, but within minutes it had lost the connection and could not see it again.
    2) Hard reset. No change.
    3) Reset Network Settings. No change.
    4) Complete restore. No change.

    I searched, but all of the threads about this issue seem to date back to 2.X, not 3.0... so, is anyone else having trouble with WiFi under 3.0? Any fixes that have worked? The phone is less than a year old, so the next step might be talking to Apple, but sadly there's no Apple store nearby so it's not quite as simple as going in and talking to a Genius. :/
     
  2. SFStateStudent macrumors 604

    SFStateStudent

    Joined:
    Aug 28, 2007
    Location:
    San Francisco California, USA
    #2
    I get disconnected on occasion and it seems that my wireless router may be the culprit. I've had to update it (Belkin N+ Router) on several occasions, but I still get disconnected at times. Since the 3.0.1 FW update, I haven't been experiencing a disconnect, then again I did another update a couple days after the FW 3.0.1 update. :confused:
     
  3. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
    #3
    How about a reset all settings or a DFU restore? Or maybe restore as a new phone? I know, no one seems to have resolved this issue.

    Yeah, but his laptop works, so that can't be it.
     
  4. jamesapp macrumors 6502a

    Joined:
    Mar 7, 2008
    #4
    I have an iPhone 3gs and just this morning I was testing out rowmote pro an app I downloaded from the AppStore. Rowmote connects my iPhone to my laptop, I create an adhoc network on my laptop and connect my iPhone to my laptop. My problem is that my wifi connection drops periodically. It drops enough that I can't use the rowmote app. I had the same problem with my 3g iPhone. I hope this gets fixed in the 3.1 update.
     

Share This Page