Still missing the first letter

Discussion in 'iMac' started by jimuk, Nov 20, 2012.

  1. jimuk macrumors newbie

    Apr 7, 2011
    My mac sometimes misses the first letter or dumps the first letter typed into the middle of a word. Its diving me crazy. I did some research and it seems people were moaning about this in 2006. Surely it's been fixed by now!

    Let's say I am about to type the word Rabbit I'll often get "abbit" or even worse "abRbit" Where by its remembered the first letter typed and dumps it anywhere into the word when it's woken up. Anyone know what I can do to stop this happening?

  2. ergdegdeg Moderator emeritus


    Oct 13, 2007
    Which keyboard are you using and have you tried a different one?
  3. jimuk thread starter macrumors newbie

    Apr 7, 2011
  4. jimuk thread starter macrumors newbie

    Apr 7, 2011
    Tried it with the original keyboard and its the same. Seems to need time to "wake up" Am I the only one suffering this problem? :-(
  5. swordsmn macrumors newbie

    Sep 16, 2012
    I have seen this with my 2011 MBA, built-in keyboard. Thought I had a key(s) going bad. Will be watching this thread, good luck!
  6. boy-better-know macrumors 65816

    Jun 30, 2010
    happens to me a lot on my 15" rMBP, also happened a lot on my 2011 13" MBA. I don't think it is a hardware thing.
  7. seble macrumors 6502a

    Sep 6, 2010
    Use to happen on my 2007 MacBook pro. Seems to be some software bug as I had the keyboard replaced twice on that model! Funnily I get similar problems in my iPad with Bluetooth keyboard, but not when I try it with a different make one, so hmm could be OS or hardwar!
  8. jimuk thread starter macrumors newbie

    Apr 7, 2011
  9. Nermal, Dec 11, 2014
    Last edited: Dec 27, 2014

    Nermal Moderator


    Staff Member

    Dec 7, 2002
    New Zealand
    Sorry to bump such an old thread, but did anyone ever find a solution for this? It happens on my Early 2011 MBP with Yosemite, with both the internal keyboard and a newish "flat" Apple USB keyboard.

    I've found a firmware update that claims to fix the problem, but it only works on 2007 and earlier machines.

    Edit: I most frequently run into this in the Messages app, and I've managed to figure it out :)

    If Messages is not the active app, then I can click in the reply box and type, and it'll get all keystrokes. However, if I just click in the message area instead, then it loses the first character. Now I just need to train myself to click in the box (although I'll log it as a bug).

Share This Page