Still no clock fix?

Discussion in 'Windows, Linux & Others on the Mac' started by sabre364, Jun 25, 2009.

  1. sabre364 macrumors member

    Joined:
    Jun 23, 2008
    #1
    Anybody have a clock fix that works yet? for the problem of the clock jumping 4 hours or so ahead randomly?

    I don't know how I could use it as my primary partition with this kind of issue...thats why I had to switch back to osx...:mad: A couple other reasons too but we wont get into that right now.
     
  2. Nugget macrumors 65816

    Nugget

    Joined:
    Nov 24, 2002
    Location:
    Houston Texas USA
    #2
    It's not jumping and it's not random. Windows just doesn't know how to cope with the system clock being set to UTC. I'm guessing you're in the Eastern timezone, right?

    When you set the clock in OS X it's setting the clock to UTC. Windows is lamely expecting the system clock to be set to your local time zone, so when you boot to Windows it figures your computer is in UTC.

    During the summer, UTC is four hours ahead of EDT. When daylight savings is over, it'll be five hours ahead of EST.

    This is only a problem if you switch back and forth between OS X and Windows and can probably be avoided by running some sort of automatic time setting app/utility on the Windows side. I used to run one called "Tardis" but it's been a decade or so since I cared about Windows clock accuracy, so I have no idea what the good one is these days.

    * For the record - OS X is doing the "right" thing here and Windows is doing the "wrong" thing. Setting the system clock to local time is terrible design.
     
  3. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #3
    Windows 7 and now Vista with Service Pack 2 both support UTC so in my case the bootcamp problem has gone.
     
  4. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #4
    Hmm I have the opposite problem: when I boot back to OSX from Win7, my OSX clock is like 4 hours off. It will then correct itself within 5 min, but it's kind of annoying. Does anyone know how to fix this?
     
  5. LtRammstein macrumors 6502a

    LtRammstein

    Joined:
    Jun 20, 2006
    Location:
    Denver, CO
    #5
    I get that same issue, but I just open up the Date & Time Pref and it reinitializes it.
     
  6. McShizzel macrumors regular

    Joined:
    Oct 29, 2008
    Location:
    Canada
    #6
    It happens whenever I Boot Camp in both Windows and Mac OS.

    The problem fixes itself since I'm usually connected to the internet when my computer boots up, it only displays incorrect times when I boot up offline.
     
  7. Gav Mack macrumors 68020

    Gav Mack

    Joined:
    Jun 15, 2008
    Location:
    Sagittarius A*
    #7
    Boot back into Windows 7, right click the time in the bar and select Adjust time. Select your time zone making sure that (UTC) is bracketed before your region then click ok. If that's still not working correctly then try disabling the Appletime service in services.msc and see if that helps.

    I'm running the Bootcamp 3.0 beta drivers from Snow Leopard with Appletime starting on my 7 and that OSX time jump after rebooting from XP before it connects to the time server is finally gone now I've upgraded.

    Failing that if you still have problems on 7 or Vista SP2, click start, type regedit, right click and run as administrator then browse to the following key:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\

    Look for a key called RealTimeIsUniversal = 1

    If it's not there right click in the right hand pane New, 32 Bit DWORD Value (for 7 64 bit 64bit QWORD) with the name RealTimeIsUniversal and set it's value to 1. Close Regedit then go back to the date and time properties and deselect any time server settings then reboot. Windows should now not check the time which is fixed to UTC so it's up to Leopard to set the clock.
     
  8. sundeepholani macrumors newbie

    Joined:
    Jul 30, 2013
    #8
    Re: Still no clock fix?

    I am running Windows ONLY on my MacBook air. Did a partition wipe and a native windows install, and now using Bootcamp 5 for the drivers. I was facing the same problem that the time was 5.5 hours off (I am on Indian Standard Time, which is GMT + 5.5).

    What I understand is that the Macbook's EFI has the actual time of my timezone set in the clock (which only seems changable from OSX). However, windows thinks that the hardware clock is set to UTC, and keeps setting it's own clock to hardware clock + 5.5. Even though I was manually setting the time on Windows, or asking it to sync with time servers - some service kept resetting it to the EFI clock.

    This is what got me the solution:

    Open Regedit.

    Navigate to: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation\

    Look for a key called RealTimeIsUniversal, and set it to 0.

    I guess what this does is, tells Windows that the hardware clock's time is not UTC, and Windows stops adding 5.5 hours to the hardware clock to set its own time.
     

Share This Page