General Still on 6.1, should I update to 6.1.4?

Discussion in 'Jailbreaks and iOS Hacks' started by Bitgod, Sep 17, 2013.

  1. Bitgod macrumors regular

    Bitgod

    Joined:
    Oct 25, 2003
    #1
    So both my iPad 4 and iPhone 5 are on 6.1 and I don't plan on going to 7 any time soon, especially not before its JBable. Should I update to the latest 6? I'm a little worried that at some point, new apps will require at least 6.1.4, but I may be worrying over nothing. I wasn't sure if there is a time factor here, if I need to do this now or as long as I get a copy of the 6.1.4 update, that it could be done later down the road?
     
  2. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #2
    Do you want to keep your jailbreak (if you are jailbroken)? Do you want to jailbreak (if you aren't)?

    If you answered 'yes' to either, then NO, you do NOT want to update. The current iOS 6 jailbreak only works up to 6.1.2. If you update you will lose your jailbreak or any possibility of jailbreaking until the iOS 7 JB is released.

    There is a tethered jailbreak for 6.1.3, but it's complicated. Getting to 6.1.2 alone if you have the right device is complicated.

    If you don't care about jailbreaking or losing your jailbreak then by all means, update to 6.1.4.
     
  3. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #3
    Nope.
    They wont require 6.1.4 over 6.1
    They will just require ios 7.
    I'd stay where you are till the ios 7 JB is out.
     
  4. Bitgod thread starter macrumors regular

    Bitgod

    Joined:
    Oct 25, 2003
    #4
    OK, sticking with 6.1 it is then. Yes, my devices are jailbroken and I'm happy with all the customization I've got set up. Now to see how many apps are gonna be a hassle and demand 7.
     
  5. Sedrick macrumors 68030

    Sedrick

    Joined:
    Nov 10, 2010
    #5
    Apple is still signing 6.1.3, but not 6.1.2, so you best stay where you're at. I screwed the pooch (sorry ladies) and didin't update and JB on 6.1.2, so I went ahead and got off 5.1.1 JB and went to 6.1.3, just to be compatible with most software.. May jump to 7 later with a JB comes out.
     

Share This Page