still waiting for root device.. please help!

Discussion in 'macOS' started by jimmy43, Jan 3, 2010.

  1. jimmy43 macrumors member

    Joined:
    Apr 9, 2008
    #1
    Hi everyone, my macbook pro 2.4 got force restarted a few times because it was locking up ( a friend's faulty external drive i was trying to fix).

    It was running fine, then when i tried to connect my own external drives they wouldnt mount anymore and I got this error:

    /system/..../IOStorageFamily.kext was installed improperly.

    I came here and read up on common solutions. I have:

    - Ran Disk utility repair and repair permissions
    - Followed this artilcle: http://support.apple.com/kb/TS1417
    - In verbose and single user mode all i get is the dreaded "waiting for root device" over and over.
    they all have not worked so far

    However in safe mode it actually boots. It seems to me that some drivers were perhaps corrupted when I turned it off abruptly and now it has trouble mounting any drive.

    What are my options at this point? (thanks in advance :eek:)
     
  2. analbeard macrumors newbie

    Joined:
    Jul 2, 2009
    #2
    a bit of help with this wouldn't go amiss as i'm now in exactly the same situation.
     
  3. jansan20 macrumors newbie

    Joined:
    Jan 22, 2011
    #3
    I'm aware that this is most likely past due, but i would still like to share my experience, since I couldn't find any solution on the net concernig this particular problem.

    Specs: Macbook PRO, Core2Duo, 10.6.6

    Symptoms: "Still waiting for root device" - NO sign; saveboot works (holding right shift on boot)

    Solution:
    After trying everything,

    Disk utility (on safeboot, on install disk, on another mac)
    DiskWarrior (on safeboot, on bootdvd, on anothert mac)
    fsck (even advanced options)
    pram reset
    smc reset
    etc. in all possible configuration, by even removing the disk from the unibody case and attaching it via USB to another mac.

    I finally found a solution. These failures are always due to faulty BIOS settings or faulty kexts on OSX86. But since I am on a MacbookPRO, there is no BIOS.

    Long speech short

    Replace IOStorageFamily.kext in /System/Library/Extensions with one from a working mac, or from the installation disc using Pacifist, or whichever way you prefere.

    Fix permissions and ownership, repair permissions with discutility. Remove caches.

    And you are good to go.

    I can imagine that sometimes other kexts may be the faulty ones. In such cases it is always good to analize verbose mode first.

    This is how I managed to fix my problem without having to reinstall.
     

Share This Page