Still Waiting on root device??!!?

Discussion in 'OS X Yosemite (10.10)' started by TracyDJMan, Jun 7, 2016.

  1. TracyDJMan macrumors newbie

    TracyDJMan

    Joined:
    Jun 7, 2016
    #1
    Hello! I haven't been on my computer for awhile and I'm running 10.10 and it automatically updated something and now OSX won't load... it's been running great up until this point. Dual boot system, windows still boots. REfind isn't loading anymore though. Can I fix refind from windows? is that the issue?

    Thanks for your help!
     
  2. TracyDJMan thread starter macrumors newbie

    TracyDJMan

    Joined:
    Jun 7, 2016
    #2
    I'm wondering if it has something to do with Chameleon SSD optimizer. Is there a way to disable this from the terminal?
    --- Post Merged, Jun 7, 2016 ---
    Problem Solved!

    Getting back into OS X
    Follow these steps to disable kext-signing and rebuild your kext cache.
    Step 1: Boot recovery mode by holding Cmd+R during boot
    Step 2: Is your volume encrypted (FileVault)? If so, first open Disk Utility from the menu bar and unlock/mount your drive
    Step 3: Open the Terminal from the menu bar
    Step 4: Run this command:

    nvram boot-args
    Does it say “kext-dev-mode=1”? if so, you can skip to Step 6. If it says “error getting variable”, continue with these steps:
    Step 5: Run this command:

    nvram boot-args=kext-dev-mode=1
    Step 6: Reboot back in to Recovery Mode again
    Step 7: Run these commands, replacing Your Disk Name with the name of your Mac disk volume. If the volume name contains spaces, use quotes around it.

    touch /Volumes/"Your Disk Name"/System/Library/Extensions
    kextcache -u /Volumes/"Your Disk name"
    Step 8: Wait until it finishes (can take as long as 5-10 minutes, don’t abort it) and reboot.
    You should now be back in OS X with Trim enabled.


    https://www.cindori.org/trim-enabler-and-yosemite/
     
  3. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #3
    It's not unusual for a lot of things to knock rEFInd out from being the priority bootloader. Since this happened right after an OS X update, almost certainly it was the update that did it.

    You've already solved the problem, but in the future here is Rod's page about getting rEFInd back as the priority bootloader:
    http://www.rodsbooks.com/refind/bootcoup.html

    (And yes, you can do it from Windows. Or OS X, Linux, etc. I've only ever fixed this in Linux.)
     

Share This Page