Stop Auto-Emoji in Messages.app

Discussion in 'OS X Mavericks (10.9)' started by Bendy Walker, Jul 25, 2013.

  1. Bendy Walker macrumors regular

    Bendy Walker

    Joined:
    Jan 29, 2008
    Location:
    Manchester, UK
    #1
    Does anyone know how to prevent certain emoji from replacing standard text emoticons in Messages.app?

    For example, :) = #, :p = # and :D = #.

    I prefer not to use emoji for consistency and parity across all the platforms and forums in which I use emoticons, and the fact that Messages.app now seems to auto-insert certain emoji characters is very frustrating.

    I've looked in Preferences, and in the different Menu Bar items, but cannot find an option to disable this.

    Any suggestions?
     
  2. mathiasbynens, Oct 23, 2013
    Last edited: Oct 23, 2013

    mathiasbynens macrumors newbie

    mathiasbynens

    Joined:
    Oct 23, 2013
    Location:
    Belgium
    #2
    I just found the solution: https://github.com/mathiasbynens/dotfiles/commit/f10eb803cf9cb9ed321bc60e92f662353400a38c There are some other hidden preferences for Messages, too. They’re listed on that page as well.
     

Share This Page