Stop command from executing at terminal start

Discussion in 'Mac Programming' started by toppy42, Oct 2, 2011.

  1. toppy42 macrumors newbie

    Joined:
    Oct 2, 2011
    #1
    Hey, not sure if this is the correct place to ask but I'm not sure where else it would go.

    A while back, I installed zsh, but couldn't figure out how to set it as my default shell (I figured it out last night). Instead, I somehow set up terminal to autoexecute zsh at startup. Now that I've changed the default shell, I would like to get rid of that, but don't remember how. I don't have a .profile, bash_rc, bash_profile or anything else of the sort in my home folder.

    Any ideas?
     
  2. lloyddean macrumors 6502a

    Joined:
    May 10, 2009
    Location:
    Des Moines, WA
    #2
    Terminal.app -> Preferences -> Settings -> Shell
     
  3. willieva macrumors 6502

    Joined:
    Mar 12, 2010
    #3
    In the terminal preferences, make sure Startup has shells open with default login shell, and under settings there is no Startup command indicated.

    If you used chsh to change which shell you use, then you'll need to revert to bash by running chsh again:
    chsh -s /bin/bash `whoami`
     
  4. toppy42 thread starter macrumors newbie

    Joined:
    Oct 2, 2011
    #4
    Thanks, that was exactly it. Feel pretty silly for not checking that.
     
  5. larkost macrumors 6502a

    Joined:
    Oct 13, 2007
    #5
    Note: there is no reason to separately install zsh. It is part of the standard MacOS X setup.
     

Share This Page