stop iphone from roaming to mexico

Discussion in 'iPhone' started by billy3785, Jul 22, 2010.

  1. billy3785 macrumors regular

    billy3785

    Joined:
    Sep 3, 2008
    Location:
    NYC
    #1
    i work close to the border in San Diego (about 15 miles away,really) but whenever I'm at work when it should and CAN pick up an AT&T signal, 50% of the time it roams to TELCEL or MOVISTAR. is there any way to STOP the iphone from choosing these carriers and just have AT&T or even NO SERVICE. This is driving me crazy!
     
  2. trekkie604 macrumors 65816

    trekkie604

    Joined:
    Feb 25, 2008
    Location:
    Vancouver, Canada
    #2
    Can you just select AT&T in Settings > Carrier and make sure Automatic is unchecked?
     
  3. ccolaco macrumors 6502

    Joined:
    Jul 5, 2007
    #3
    Next time your at work, go into settings > carrier and select AT&T. It may be set to automatic right now and could just be automatically choosing the Mexcian network. See if that helps.
     
  4. billy3785 thread starter macrumors regular

    billy3785

    Joined:
    Sep 3, 2008
    Location:
    NYC
    #4
    sometimes i have the carrier option, sometimes i dont. when i do have it, only automatic shows with the spinning wheel
     
  5. Goldinboy17 macrumors 65816

    Goldinboy17

    Joined:
    Jun 21, 2010
    Location:
    San Francisco, Ca
    #5

    Go break those cell towers? Settings > General > Network > Data Roaming "OFF." That should at least prevent you from using data? Not sure if that's your problem, or you use your cell phone to make constant calls and you are being connected to those towers.
     
  6. billy3785 thread starter macrumors regular

    billy3785

    Joined:
    Sep 3, 2008
    Location:
    NYC
    #6
    data roaming it off, but it is still connecting to those towers. and often I do get text messages coming in while i am on those networks
     
  7. ramallite macrumors regular

    Joined:
    Jan 5, 2004
    Location:
    Greensboro
    #7
    From your AT&T online account page, or from the iPhone's "myWireless" App from AT&T which you can download for free, de-select the "Expanded International Roaming" option. You may have to call AT&T directly to do this because, as it is a free add-on, it may not be easy (or possible) to disable manually.
     
  8. trekkie604 macrumors 65816

    trekkie604

    Joined:
    Feb 25, 2008
    Location:
    Vancouver, Canada
    #8
    You have to wait for the phone to finish scanning for carriers after clicking Carrier for AT&T to show up. Choose AT&T and the checkmark should disappear from the Automatic option.
     
  9. Andrew K. macrumors 65816

    Joined:
    Jul 9, 2008
    #9
    I had my local AT&T store put a block on Mexico where I live, or just call AT&T customer service they can do it too.
     
  10. marksman macrumors 603

    marksman

    Joined:
    Jun 4, 2007
    #10
    I turn my cell phone off before going to the donkey shows.
     
  11. MikieMcBikie macrumors regular

    Joined:
    Mar 14, 2009
    Location:
    TN
    #11
    so off topic but...and i apologize to Op...


    LMFAO!
     

Share This Page