Stop iTunes from automatically importing/playing MP3s downloaded in Safari?

Discussion in 'Mac Apps and Mac App Store' started by benguild, Oct 21, 2011.

  1. benguild macrumors 6502a

    Joined:
    Jul 29, 2003
    #1
    It happens so fast! So annoying! Stops whatever I'm listening to, as well.
    I'm not talking about the store links. I'm talking about if I save a file in Safari that's an MP3 (for example) ... iTunes just immediately grabs it.

    How can I disable this behavior?
     
  2. yongren macrumors regular

    Joined:
    Jan 19, 2011
    #2
    Go to Safari preferences, uncheck "Open safe files after downloading" in the General tab

    Alternatively, make Quicktime the default player for audio files, so they automatically open there instead of in iTunes
     

Share This Page