Stop osx from renaming external harddrives!

Discussion in 'macOS' started by booyaaah, Jun 3, 2010.

  1. booyaaah macrumors newbie

    Joined:
    Jan 11, 2010
    #1
    Hi!
    I have an annoying problem when I start up my external hdd in OSX.

    Let's say the location for the disk is: /Volumes/disk A

    Sometimes (often) after a reboot or just a restart of the external hdd in OSX the location becomes: /Volumes/disk A 1

    The system adds a 1 to the location of the disk!?!?

    This is really annoying because my torrents will be ****ed up because the location of existing downloads can't be found and it's the same with my usenet client. The only way I've managed to solve the problem is to try to restart osx + external hdd until the location becomes /Volumes/disk A again (or recheck ALL torrents to the new location:().

    I haven't found any logic when it goes back to the original place yet so often it takes a while to get it right. :mad:

    Please help me if you know a way to make this stop!
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    The adding of a 1 indicates that OSX thinks the drive with the other name already exists. Make sure the drive is unmounted properly before shutting down because it doesn't look like it is. What brand is the drive? Maybe others have had similar issues.
     
  3. booyaaah thread starter macrumors newbie

    Joined:
    Jan 11, 2010
    #3
    Thanks for the reply!

    Its 2 x WD15EARS in a stardom decktank with appleraid concatenated mode.

    Is there a way to be sure the it unmounted correct or a program that does it correctly? I usually just press the eject button in finder.
     
  4. Consultant macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #4
    It only does that only when you have another drive of the same name.

    When that happens it does NOT change the drive name permanently, it only changes the displayed name.
     
  5. larkost macrumors 6502a

    Joined:
    Oct 13, 2007
    #5
    If you want to be sure that something always gets the same mount point, then you have to mount it somewhere outside of /Volumes (where dynamic names are the general rule). This can be be done using the volume uuid and /etc/fstab (yes, it still works in 10.6).
     
  6. iThinkergoiMac macrumors 68030

    Joined:
    Jan 20, 2010
    Location:
    Terra
    #6
    Are you using Transmission? I've found that Transmission really messed up those location directories. When you start Transmission without the external drive attached, instead of saying it can't find the drive it simply creates the directory.

    For example, say I have a drive called "ExtHDD" and I'm torrenting the latest release of Ubuntu to it. So the location is:

    /Volumes/ExtHDD/

    If I start Transmission and don't have the drive mounted, it just creates that directory and starts again. So when I mount the drive again it becomes:

    /Volumes/ExtHDD 1/

    Maybe this is the issue you're having?
     
  7. booyaaah thread starter macrumors newbie

    Joined:
    Jan 11, 2010
    #7
    interesting. I googled volume uuid and found this thread: Mac OSX Hints

    It's about setting up a firewire drives mount point but it looks a bit complicated to me. :( Found a comment to the article which describes my problem exactly:

    "Another reason you might need to do this:

    I lost power on an external drive, and when it came back up online its mount point was "/Volumes/[drivename] 1" instead of "/Volumes/[drivename]".

    I have documents that rely on absolute-linked files -- those links are now broken because of the mount point name change."

    Thanks for the reply!
     
  8. booyaaah thread starter macrumors newbie

    Joined:
    Jan 11, 2010
    #8
    I use deluge as a torrent client and it messes up the location directories too :(
     

Share This Page