Stop ppp setting name servers?

Discussion in 'macOS' started by jman70, Feb 10, 2008.

  1. jman70 macrumors newbie

    Joined:
    Feb 10, 2008
    #1
    I'm perplexed that in Linux I can omit the option usepeerdns, and in WinXP you can choose "Obtain DNS server address automatically" or "Use the following DNS server addresses", but when you connect using PPP in OS X 10.5.1 you have the peer name servers appended to your resolv.conf whether you like it or not.

    I know you can set the name servers with scutil as root, but is there a configuration file somewhere to stop ppp using "usepeerdns"? I need this because I don't trust my ISP's nameservers.

    Thanks for your help!
     
  2. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #2
    I think pppd is the underlying program. You can try adding whatever options you like in /etc/ppp/ppp.options or ~/.ppprc and see if they have effect.
     
  3. jman70 thread starter macrumors newbie

    Joined:
    Feb 10, 2008
    #3
    The file is /etc/ppp/options - you can find that out by typing "man pppd" in the terminal.

    So tell me, what option overrides usepeerdns once it is set by Internet Connect? I don't think there is one, but obviously you know better! :)

    What I am interested in is the configuration file for Internet Connect, or a way to stop Internet Connect setting usepeerdns.
     
  4. Amdahl macrumors 65816

    Joined:
    Jul 28, 2004
    #4
    Actually, I have no idea. But there usually is a way to accomplish anything with pppd. Perhaps you can make your own /etc/ppp/ip-up script that resets the DNS back to what you want?
     

Share This Page