Stop reading PDF's in Safari? Open with Acrobat.

GimmeSlack12

macrumors 603
Original poster
Apr 29, 2005
5,396
7
San Francisco
Is there a way to stop PDF's from opening inside of Safari? I figure there is some type of solution to this but I can't be bothered to figure it out myself as I have wasted too much too much time on it already.
 

mufflon

macrumors 6502
Sep 15, 2006
264
2
there's always right click->save as - which would emulate how it was handled before (but you'll have to open the document once on your harddrive).

Another solution might be to somehow change the mime for pdf to download rather than read, but dunno if that is even archievable.

gl anyhow :)

edit: I found a way!

write this in your terminal
Code:
defaults write com.apple.Safari WebKitOmitPDFSupport -bool YES
change to NO if you want to change back to how it is now
 

GimmeSlack12

macrumors 603
Original poster
Apr 29, 2005
5,396
7
San Francisco
Ahh, thank you much Mufflon, it took a combination of you're Terminal code and to remove the PDF internet plug-in. And now it works how I want.
 

Mr Skills

macrumors 6502a
Nov 21, 2005
802
1
Just out of interest, is there a particular reason why you would rather use Acrobat than Preview?

.

.
 

Pittsax

macrumors 6502
Dec 8, 2004
445
0
Toronto, Ontario
I have a similar question: I remember in a previous version of Safari/Acrobat, the PDFs that opened in Safari had the complete Acrobat toolbar displayed as well. This was handy, since I could do everything from Safari without having to download and re-open the file. Is there any way to get this functionality back?
 

uaaerospace

macrumors 6502
Feb 15, 2005
396
0
Alabama
Pittsax said:
I have a similar question: I remember in a previous version of Safari/Acrobat, the PDFs that opened in Safari had the complete Acrobat toolbar displayed as well. This was handy, since I could do everything from Safari without having to download and re-open the file. Is there any way to get this functionality back?
Try this...

Log in to your admin account.
Quit Safari.
Open Acrobat Reader or Professional
Hit CMD-K (alternatively, go Acrobat menu > Preferences)
Click Internet
Make sure the two options "Display PDF in browswer using Adobe Acrobat" and "Check browser settings when starting Acrobat" are checked.
Log out of admin and back into your regular account and try the PDF again in Safari.
 

GimmeSlack12

macrumors 603
Original poster
Apr 29, 2005
5,396
7
San Francisco
Mr Skills said:
Just out of interest, is there a particular reason why you would rather use Acrobat than Preview?
I find that Acrobat allows navigation through PDF's easier than Preview. On a small iBook (12") I do not like to have the Drawer taking up screen space.

[Gives Preview another look]

After looking through Preview again and Acrobat with the same file it is actually not as bad as I remembered. Might be the case where I never gave Preview a chance.
Also the difference in memory of these two programs is significant.
UAAerospace that is a good solution too.
 

DrGroove

macrumors newbie
Apr 28, 2009
1
0
Tinkertool

Tinkertool disables native PDF support in Safari with one click (and a Safari restart).

I generally want to refer to PDFs later on (so I want it downloaded anyway), and the lag in Safari displaying the contents of a PDF inline really, really bugs me. (So that's why I want it disabled).
 

GimmeSlack12

macrumors 603
Original poster
Apr 29, 2005
5,396
7
San Francisco
Guys, this thread is years old. In getting PDF's for my dissertation the opening of files in Safari was annoying. Thank god I am said and done with the dissertation and I have purchased myself a big 24" iMac to quickly move through files. Grad school pays!

Good suggestions though.