Stop sending iMessages to a certain person

Discussion in 'iPhone Tips, Help and Troubleshooting' started by doodledee, Oct 23, 2011.

  1. doodledee macrumors newbie

    Joined:
    Oct 23, 2011
    #1
    My husband's iPhone made a disastrous fall in to the toilet. Due to our finances he is using a blackberry that AT&T sent to us for free.

    My problem is that as long as the iMessage feature is turned on, my phone keeps sending him iMessages!

    I have been going crazy searching for an answer, so please forgive me if there is a simple solution. Thank you soooo much for your time!!
     
  2. verwon macrumors 68030

    verwon

    Joined:
    Jul 26, 2011
    Location:
    Seattle
  3. doodledee thread starter macrumors newbie

    Joined:
    Oct 23, 2011
    #3
    blue
     
  4. Kashika macrumors regular

    Joined:
    Sep 8, 2010
    #4
    Turn off 3G and cellular data. So that your iPhone is not connected to any form of internet.

    Texting should then change into regular SMS.
     
  5. doodledee thread starter macrumors newbie

    Joined:
    Oct 23, 2011
    #5
    Ok, so I wanted to update because my biggest pet peeve is when I find someone with a similar problem online but there isn't a resolution. Here was my solution.

    Liked I said, i did everything, deleted the contact, deleted the conversation nothing would stop sending my husband imessages even though he didn't have an iphone - and I didn't want to turn imessages off because i use the imessage feature with other people.

    So I finally realized (by accident) that you can tap on the text message you just sent, (the blue bubble imessage) and it'll ask "copy" or "send as sms"...and I chose send as sms.

    After doing this about 5-6 times, it stopped automatically sending him imessages and started automatically sending him SMS messages instead!
     
  6. wellok macrumors 6502

    Joined:
    Oct 12, 2011
    #6
    Thank you for coming back to post the solution for others. I hate when people don't do that!
     
  7. lucifiel macrumors 6502a

    lucifiel

    Joined:
    Nov 7, 2009
    Location:
    In your basement
    #7
    I too would like to express my appreciation to the OP for returning to post a solution for us to try.

    Thanks!
     
  8. Kaur22 macrumors newbie

    Joined:
    Sep 29, 2012
    #8
    Hello everyone! I figured out a solution to this problem which worked for me. We bought an iphone second hand from someone and wanted to use it for a few days and then sell it to someone. My dad used it for a few days and then decided to put his sim back to his old samsung note. But i could not send him text msgs, my iphone will automatically send imsgs to his iphone which didn't have any sim in it. So i tried different things to stop it but ended up resetting my settings in the iphone that was recieving imsgs for no reason. That fixed everything. Now my msgs go straight to my dad's samsung note.
    Hope this is helpful to someone.
     
  9. jordy93 macrumors newbie

    Joined:
    Oct 30, 2012
    #9
    is there away to do this but in reverse? i was messaging my GF and imessage went down for a bit and so it reverted back to sms messages and now that its working we cant turn imessage back on
     
  10. laurajorgen macrumors newbie

    Joined:
    Oct 30, 2012
    #10
    So i tried different things to stop it but ended up resetting my settings in the iphone that was recieving imsgs for no reason.[​IMG]
     
  11. Ellerwind macrumors newbie

    Joined:
    Mar 29, 2016
    #11
    I love you right now. I was going out of my mind trying to stop this problem. I only had to do it once and it looks like it fixed for good. If it comes back I know to keep trying. TYVM
     
  12. GalFieri macrumors regular

    GalFieri

    Joined:
    Mar 4, 2016
    Location:
    California
    #12
    Shouldn't they deregister from iMessage instead of driving you or anyone else nuts from having to do that?
     

Share This Page