Stop the "Problem connecting to server" alerts

Discussion in 'Mac Basics and Help' started by enectrixx, Mar 17, 2015.

  1. enectrixx macrumors newbie

    Joined:
    Jun 25, 2010
    #1
    I have an MBA with 10.10 that I've setup to automatically connect to a directory on my NAS automatically, but since I'm away from home a lot I get alerts all the time that there was a problem connecting to the server (which is to be expected, since it's trying to connect to a local IP). I want it to still connect automatically whenever it can, I just don't want it to notify me when it can't. Is there any way to disable the alerts without removing the directory from my login items?
     
  2. mathcolo macrumors 6502a

    Joined:
    Sep 14, 2008
    Location:
    Massachusetts
    #2
    Is it the prompt that says "There was a problem connecting to the server..." with an OK button? If so, I don't know of an OSX extension that would disable this currently, but I can write one. Let me know.
     
  3. enectrixx thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #3
    Yeah, it's that one. It would be awesome if you could write one :)
     
  4. mathcolo, Mar 24, 2015
    Last edited: Mar 24, 2015

    mathcolo macrumors 6502a

    Joined:
    Sep 14, 2008
    Location:
    Massachusetts
    #4
    Alright, here it is! First you'll need to download EasySIMBL to use the extension. So get that going, make sure the "Use SIMBL" checkbox is checked. Then download the extension (it's attached), unzip, and drag the .bundle into EasySIMBL. Then try connecting to a nonexistent server. Should work, at least on OSX 10.10.2 :)

    EDIT: (Source code for the extension if anyone is interested: https://github.com/mathcolo/ConnectionErrorDisable)
     

    Attached Files:

  5. enectrixx thread starter macrumors newbie

    Joined:
    Jun 25, 2010
    #5
    Thanks a lot! :)
     

Share This Page