Strange 10 second delay after pressing power button, display shows white screen.

Discussion in 'MacBook Pro' started by Philflow, Jun 5, 2011.

  1. Philflow macrumors 65816

    Joined:
    May 7, 2008
    #1
    The last few days I tried a couple of SATA III SSDs in my Macbook Pro 13" early 2011. One worked, some didn't. After that I went back to a SATA II SSD (Kingston V+ 100) that I was using before. I have this strange problem now.

    After pressing the power button there is a long pause 10-15 seconds where nothing happens. A white screen is displayed. After that the apple sign shows up and the booting begins.

    The Kingston SSD that first booted in 15 seconds now boots in about 30 seconds. The same goes for an Intel X25m SSD and other HDDs and SSDs.

    Also the installing process now takes much longer. Before OS X installed in 22 minutes on the SSD, now it takes over 30.

    I tried doing a clean install but that didn't work. Any ideas? Thanks in advance.
     
  2. jenzjen macrumors 68000

    Joined:
    Aug 20, 2010
    #2
    I forgot which one worked for me but do the 3 things, SMC reset, PRAM reset and make sure your SSD is selected as the boot disk under startup in system preferences.
     
  3. Simmity macrumors newbie

    Simmity

    Joined:
    May 9, 2010
    #3
    During the white screen the EFI is looking for bootable devices. There is no default bootable device selected since you have switched harddrives. To solve this, boot into OSX en go to system preferences. Go to 'select startup disc' and then select the the OSX partition. Reboot and it should be fine.
     
  4. Philflow thread starter macrumors 65816

    Joined:
    May 7, 2008
    #4
    Resetting the PRAM did wonders. Thanks for the suggestions!
     
  5. Nielsenius macrumors 6502a

    Joined:
    Apr 16, 2011
    Location:
    Virginia
    #5
    I had the same issue after installing my new SSD. Thanks for the help!
     

Share This Page