Strange 3GS issue when unlocking

Discussion in 'Jailbreaks and iOS Hacks' started by tiblua, Mar 28, 2010.

  1. tiblua macrumors newbie

    Joined:
    Mar 28, 2010
    #1
    Hi all,

    I have been a lurker on here for a long time but have never had the need to post until now. I am having a really weird problem with my 3GS and haven't been able to find any solutions on any forums. I have posted this problem on another forum but no one seems to know the answer

    I am on T-mobile UK and have a 3GS running 3.1.2 & baseband 5.11.

    On Thursday, I was out and about when the phone ran out of signal. I switched airplane mode on as I usually do when my signal drops out. The phone crashed and switched off and has been displaying the white apple logo screen, switching itself on & off randomly and getting quite warm. When I got home, I put it into restore mode and tried to restore with itunes. When I alt+clicked and chose the firmware (3.1.2) I had used before, I got the error message saying something like the device isn't eligible for the requested build. So I tried a different custom firmware and it worked fine.

    Then I tried to jb with blackra1n via my computer (as usual). The process seemed to work fine but no logo appeared on the springboard, however I could install my apps so I assume the jailbreak worked. I went via cydia to unlock with blacksn0w through there and after I had run this, the phone slowed right down and just said "searching" in the signal bar area. So I tried airplane mode again and.... the phone crashed AGAIN. I have tried this three times and every time the same thing happens. I have a feeling its something to do with an update in Cydia...?

    Does anyone have any ideas what I can try next? I have my SHSH stored on Cydia but I don't really know if this will help. I am thinking if I can get blackra1n installed okay on the phone I will be able to unlock with no problems but I'm not sure what to try next.

    Any help would be GREATLY appreciated
     
  2. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #2
    so

    are you 3.1.3 now if so you have no option but SHSH right now!
     
  3. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008
    #3

    Please go to this site. It talks about the same problems that you have, and how to fix it:
    http://extechblog.wordpress.com/201...-11-07-baseband-3gs-no-shsh-on-file-solution/

    Cydia, or blackra1n is not the problem, it's blacksn0w. I suggest that after you follow the instruction on that website, you should install blacksn0w RC2 (instead of the original version that is in blackra1n) from this repo: cydia.pushfix.info
     
  4. tiblua thread starter macrumors newbie

    Joined:
    Mar 28, 2010
    #4
    Aah, amazing! I have managed to fix it now using the solution on that site, thank you so much! :D
     
  5. mreddys10 macrumors regular

    Joined:
    Jul 29, 2008

Share This Page