Strange Admin privileges, cant install apps

Discussion in 'macOS' started by Moonkea, Dec 11, 2008.

  1. Moonkea macrumors newbie

    Joined:
    Mar 11, 2007
    #1
    Hi everyone,

    We've got some new iMacs in our college Art Department, and the admin account privileges seem quite strange - we can unlock and access panels in system preferences, make other standard users into admins too and so on, but we're getting error messages installing various applications due to not being an administrator or having privileges: "The software to be installed requires Administrator or higher level access privileges." for example.

    We've tried multiple admin accounts, we've set up new ones, we've gone through the Leopard set up from the single user mode to create a new account, we've gone through the root user to do the same thing, we've verified and repaired disk permissions and still no luck.

    Since having done that, we updated from 10.5.2 to 10.5.5, and have tried the admin accounts once more, again to no luck. Haven't gone through root or anything to try that angle again.

    That lot has only been attempted on one of our iMacs, but that error message in the first paragraph has happened on at least two of five new iMacs, perhaps all of them.

    The last thing to successfully install on these iMacs was Microsoft Office 2008. I'm not saying its the cause here, but that's up to date too and still no progress. Somethings happened between installing that on Tuesday 9th, and trying to install Final Cut Pro today. Heck, it may even have happened before Tuesday and Office just seemed to work, we just don't know.

    As for the eMacs and 10.4.11, same login set up, same applications, works slower, but works, everything's installed fine.


    Has anyone got a clue on what's going on here? Thanks in advance for any and all help, we're throwing it out to everyone who may have an idea.
     
  2. Sky Blue Guest

    Sky Blue

    Joined:
    Jan 8, 2005
    #2
    Has anyone changed anything in /etc/authorization ? Maybe back that file up and copy a new one across from a known good installation.
     
  3. Moonkea thread starter macrumors newbie

    Joined:
    Mar 11, 2007
    #3
    To my knowledge, not at all, no.

    What sort of things would change anything in there? Could clumsy mouse clicks be to blame? Seems not if its happening on all the iMacs, unless we're that clumsy.

    We've only done the single user mode once, and our collective Terminal knowledge isn't exactly brilliant, so we wouldn't be going into there without written notes and research.
     

Share This Page