Strange Album Art Behavior in iTunes

Discussion in 'Mac Apps and Mac App Store' started by SkipperStyle, Nov 19, 2008.

  1. SkipperStyle macrumors newbie

    Joined:
    Nov 8, 2008
    Location:
    Paraguay
    #1
    I normally have no trouble using the "Get Album Artwork" feature. Whenever iTunes can't find one, I just use google image search. However, one album is giving me some trouble. Obviously this isn't serious, but it has become an itch that I can't scratch.

    I click and drag a picture for these tracks, it looks like it worked, then I deselect the songs. When I go back, the image is gone.

    Has anyone else run into albums that behave strangely like this?
     
  2. thomahawk macrumors 6502a

    thomahawk

    Joined:
    Sep 3, 2008
    Location:
    Osaka, Japan
    #2
    i ahve the totally opposite of you,
    itunes gives me an error when searching for album art, and the song is in the exact info as on the itunes store..
     
  3. millar876 macrumors 6502a

    millar876

    Joined:
    May 13, 2004
    Location:
    Peterhead, Scotland UK
    #3
    try selecting the song then hit :apple:+i (for mac, think its ctrl+i for Win) to get info, go to the artwork paine and paste/drag the desired artwork into there then hit ok/done (whatever it is cant remember right now) and that should do the trick for you. I think by just dragging it into iTunes (randomly?) You are adding it to the library.

    You can do this with entire albums too, just select all the songs from that album adn hit :apple:+i. it brings up a slightly diferent window but its the same idea.
     
  4. SkipperStyle thread starter macrumors newbie

    Joined:
    Nov 8, 2008
    Location:
    Paraguay
  5. millar876 macrumors 6502a

    millar876

    Joined:
    May 13, 2004
    Location:
    Peterhead, Scotland UK

Share This Page