Strange - Audio over HDMI - Flash problem

Discussion in 'MacBook Air' started by bp1000, Sep 10, 2011.

  1. bp1000 macrumors 65816

    Joined:
    Jul 7, 2011
    #1
    Another reason to HATE flash

    I've just connected my MBA to my HDTV - i was stumped because youtube plays audio and video no problem. But all my Video on demand sites don't output audio to my tv.

    With HDMI connected i don't get audio at all, even if i select my laptop as the output channel.

    I then figured out that youtube is set to play HTML5. I get audio on my TV if i play html5 videos but i get no audio if i play any flash video, even on youtube.

    What the hell is that about! Using chrome browser.
     
  2. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #2
    Try to use Safari, do you experience the same issue?
     
  3. bp1000 thread starter macrumors 65816

    Joined:
    Jul 7, 2011
    #3
    I dont know if this issue has manifested itself from the planets aligning, i.e. a highly unlikely event but earlier i downloaded the security update for lion, hadn't rebooted to complete the update and in the meantime plugged in the HDMI adapter for the first time.

    After my reboot the flash audio over HDMI is working fine, as well as the html5 audio, both in chrome.

    Very very strange, but at least it's working now. Perhaps os x, installs some type of config for audio passthrough when connecting a HDTV and because my system was in a state of OS update it needed a reboot before the config for the HDTV could be applied.... That's my wildest guess.
     
  4. ct2k7 macrumors 603

    ct2k7

    Joined:
    Aug 29, 2008
    Location:
    London or Florida
    #4
    Maybe it's the reboot. Glad to see it's ok now :D
     
  5. jsolares macrumors 6502a

    Joined:
    Aug 8, 2011
    Location:
    Land of eternal Spring
    #5
    Did you close and reopen chrome before rebooting? i've found with VLC that if it's running and you connect the TV the audio will still come out of the computer regardless of preferences, i had to close and restart VLC
     

Share This Page