Strange behavior when typing quotes ' "

Discussion in 'macOS' started by musicelect, Mar 14, 2011.

  1. musicelect, Mar 14, 2011
    Last edited: Mar 15, 2011

    musicelect macrumors newbie

    Joined:
    Jul 10, 2008
    #1
    Just a couple of hours ago I began experiencing some strange behavior with single ' and double " quotes. When I type a single or double quote an underline appears under it and seems to be waiting for additional input. Inside Dreamweaver, if I type anything after the quote it becomes a closing single or double quote. Outside Dreamweaver no other quotes appear, but I get a beep from the system like I tried to do something illegal when I press an arrow key. I have to press the space bar twice to actually enter a space following a quote. Other text is entered immediately. The screenshots below show the strangely underlined quotes.

    [​IMG]

    [​IMG]

    In a finder window the quotes receive an orange background:
    [​IMG]

    Furthermore, if I type a single quote followed by the letter (a, c, e, o, i, u, A, C, E, I, O, U) I get a special character like:
    [​IMG]
    [​IMG]
    These special characters can be created normally in OS X by typing option or option+shift and the letter. I'm not sure why the single quote is acting like an option key.

    At first I thought it was just Dreamweaver doing something annoying, but I've found it is happening in just about any application that I can type in. I can't think of any recent changes to my system - no app installs or updates. I checked the Universal Access and Keyboard Preference Panes and saw nothing that would cause this wierdness. I'm trying to kill apps to see if one is causing this issue. This is very frustrating and I don't even know how it started. Any ideas?

    Mark
     
  2. musicelect thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #2
    I've repaired permissions in Disk Utility and booted into safe mode. Still happens. I'm going to re-install Snow Leopard and see if that fixes it.

    Mark
     
  3. Pndrgnsvc macrumors 6502

    Pndrgnsvc

    Joined:
    Jun 13, 2008
    Location:
    Georgetown, Texas
    #3
    Does the problem occur regardless of the font used?
     
  4. musicelect, Mar 15, 2011
    Last edited: Mar 15, 2011

    musicelect thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #4
    Just finished a re-install of Snow Leopard (not an erase and install). The problem still exists.

    Yes, this issue occurs wherever I can enter text, regardless of the font. It happens in the Finder window search field, firefox url and search box, Text Edit, Thunderbird (To, subject, body fields), etc. As much as I hate to do this, I'm going to start backing up files to do a complete erase and install. I know this is not normal OS X behavior and an erase and install should do the trick. Of course, a simpler solution would be nice. If anyone has a clue as to what is going on, please advise.

    Mark
     
  5. itickings macrumors 6502a

    itickings

    Joined:
    Apr 14, 2007
    #5
    Create a new user account and see if the problem persists. That'll narrow it down quite a bit.

    But go ahead and start backing up your files anyway, you should always have a fresh backup even when you don't expect to need it. :D
     
  6. musicelect thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #6
    I have a backup on my Time Capsule, but I will make a manual backup of stuff I really want to keep.

    So the re-install went good. I was looking around in System Prefs to see if there was some goofy option to make the single quote act as an option key. I didn't find anything and went to restart my computer again. I got the circle with the slash upon startup. I haven't seen this before, but it used to be the broken folder icon which means there is something wrong with the os install or the hard drive.

    So another disk permission repair and verify disk via booting from the install disk says my drive is fine, but I'm gonna have to re-reinstall the OS.


    Stay tuned,

    Mark
     
  7. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #7
    +1 for trying a new account

    Why are you considering another OS install if you haven't tried creating a "test" account? If the problem persists with the test account, then and only then would I consider another OS install.
     
  8. musicelect thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #8
    I'd create another user account if I could, but I got the circle with the slash upon startup which means Mac OS X won't boot. I'm restoring from my Time Capsule now.

    Mark
     
  9. musicelect thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #9
    I'm back up and running. Created a new user and the problem is not there. I also logged into another user account that has been around a while and there is no problem there either. It seems that the issue only affects one user account, my usual account. What does this mean?

    Mark
     
  10. musicelect thread starter macrumors newbie

    Joined:
    Jul 10, 2008
    #10
    Thanks to TeenTitan for solving my problem over on the Apple Discussion forum. He suggested I change the selected input source to U.S. instead of U.S. International - PC via the input menu icon in the menu bar. I don't know how it got changed or if it even did change, but it solved the problem. My quotes are now behaving normally. Interestingly, the three U.S. input methods are still selected in System Prefs > Language & Text > Input Sources.

    Notice the American flag in the menu bar:
    [​IMG]

    What you don't want to see is this:
    [​IMG]

    Thanks for everyone's help. I hope this thread will help others who stumble upon this annoying occurance.

    Mark
     

Share This Page