Strange colors for iMessage bubbles on Mavericks?

Discussion in 'OS X Mavericks (10.9)' started by stagmeister, Oct 23, 2013.

  1. stagmeister macrumors regular

    Joined:
    Jul 17, 2004
    #1
    It seems that in iMessage on Mavericks, different peoples' messages (i.e. in different conversations) are now displayed with different colors. My messages are all in blue (they are sent as iMessages, not texts) but my friends are green, gray, pink, or orange. What's up with that?
     
  2. hamiltonDSi macrumors 68000

    hamiltonDSi

    Joined:
    Jul 29, 2012
    Location:
    Romania
    #2
    That's iChat build in the messages app.
    You can hook up Yahoo! Messenger, Google Talk, AOL, etc.
     
  3. SoloStyle macrumors regular

    Joined:
    Oct 17, 2011
    #3
    We didn't see the colors before Mavericks, but at some point your friends have went into the settings and actually changed what colors they want their chat bubbles displayed in. Maybe this was just a local setting before, but for whatever reason now these colors also display for the recipient.

    If you don't like it, you can go into the Messages preferences > viewing and change what color/font/etc you want all chat bubbles to display as.
     
  4. squeakr macrumors 68000

    squeakr

    Joined:
    Apr 22, 2010
    #4
    Do these colors stick in the other Message apps as well (such as iPad and iPhone) or do they just carry over between Mac Message?
     
  5. luigibanks macrumors newbie

    Joined:
    Oct 26, 2013
    #5
    You're all wrong

    Simply go into iMessage, Preferences, Viewing, Senders Colour Background

    Yours will be on either Automatic or random, this is why all of your messages are different colours from different senders. From here you can select the specific colour you would like. :)
     
  6. o0smoothies0o macrumors regular

    Joined:
    Aug 12, 2013
    #6
    This happened to one of my open conversations after upgrading too. Didn't change a thing in settings, never have, and I seriously doubt they did either. Likely a bug just like a million other bugs in the OS.
     
  7. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #7
    The first part of your post is wrong. You cannot change or control in any way how your messages appear on someone else's screen.

    The change is that the default color for viewing received messages has changed from "Gray" to "Automatic." Messages now gives you different colors by default, with the idea that it's easier to know who is talking to you. That's all.
     
  8. SoloStyle macrumors regular

    Joined:
    Oct 17, 2011
    #8
    That's incorrect. I've specifically tried this with various friends, while both being on a Mac. I can go in and change my color bubble to display in PINK, and it will start showing up as pink on THEIR screen, in the messages app. This, of course, assumes they have their view setting to automatic.

    It will not display as pink on their iPhone or iPad, however once set in the messages app, I can then message from my iPhone or iPad and the messages still continue to display in a pink bubble on their screen (mac).

    However, I will admit I have no idea why other's chat bubbles are showing up in various colors for people who have never owned a Mac, since these colors can't be changed on the iPhone.
     
  9. matt2053 macrumors 6502a

    Joined:
    Jul 8, 2012
    #9
    This is why I assumed it's being done automatically instead of through the Mac-side settings. My dad's iMessages are yellow now (on my Mac), but he doesn't even own a Mac, so there's no way he could have changed it himself to yellow.
     
  10. lke macrumors 6502a

    Joined:
    Jun 19, 2009
    #10
    Have the same issue. I am sure that something in the ipad or the iphone let people select what color to use to send messages in imessage.

    Later I will check why some friends messages appear in pink.

    At the moment I select clear for all sender messages to avoid that ugly pink color.
     
  11. tehroonieh MD macrumors newbie

    Joined:
    Jun 11, 2010
    #11
    I was wondering if anybody knows how to make it display the colors the way it was before. iMessages showed up as Blue/Grey and chat messages showed up as Green/Grey. Now I have no way of telling how the message is being sent unless I scroll up to check which I don't want to have to do. Any clues?
     
  12. gonzo3 macrumors newbie

    Joined:
    Nov 5, 2013
    #12
    What I found on message colors

    Two things - when you click the ? in the preferences window on the screen for viewing you are told these settings show how your messages show up for you, and how others show up for you. It would seem odd that you could change how your messages appear in other people's experience. However, with the "automatic" setting turned on you very well may get what the other user has set for their messages to appear to them.

    Also, one user asked how do they know if this is iMessage or regular text - it appears Messages is ONLY iMessages - when I tried to message a non-iPhone cell I got "‪+1 (555) 555-5555‬ is not registered with iMessage." No that's not the phone number I used - I used a real number that I know is tied to an Android phone. Then again maybe you can tie an Android phone number to iMessage and it would work - either way, in Messages it appears it's only iMessages.

    Also, my contacts are not in the OSX world yet, they are tied to a gmail account. So in Messages I don't see names, only phone numbers right now - it might help a little to have messages in different colors to help me sort conversations....but just speculating here.
     
  13. fletchni macrumors newbie

    Joined:
    Oct 26, 2011
    #13
    Well, it seems quite simple...

    ... go to preferences in iMessage, and under "read" tab and the section "senders talk bubble colour" choose the colour you want!

    (Note: my Mac is in Swedish, so maybe the English labels on your screen will not be exactly what I typed).

    Actually, I really like the idea to quickly distinguish who I'm chatting with (I did send a message last month to my son instead of my wife) but I wish they had let me choose the colour for each contact.

    Because my wife - who I message with most - has come up in a horrible purple, which simply doesn't do her justice!

    Nic.
     

Share This Page