Strange Finder behaviour

Spectrum

macrumors 65816
Original poster
Mar 23, 2005
1,431
754
Never quite sure
I'm in Safari with a number of windows open. When I approach the toolbar of the front-most window the mouse pointer disappears, and remains hidden despite being able to activate wherever it is.

This is demonstrated by the following clip. I've caused a lower window's action buttons to light up by passing over them, but no pointer to be seen.

I've just checked out activity monitor - Safari is constantly eating up all available CPU when safari is at the front...
 

Attachments


dsharits

macrumors 68000
Jun 19, 2004
1,639
0
Plant City, FL
I've had this happen before with Panther. I'm not sure if it is a bug or something else. Forunately, it doesn't happen much any more with Tiger. It can be annoying. How often does this happen to you? Is it every time you have a bunch of windows open?
 

uaaerospace

macrumors 6502
Feb 15, 2005
396
0
Alabama
I also had this problem just a few days ago. I can't remember how many windows I had open, but I do remember that it happened only to one window in safari. I had a few different web pages open in a few different windows, but only one window malfunctioned. Also, like you said, it only did it when the mouse was near the buttons on the toolbar. I'm running 10.3.9 and Safari 1.3v312. Josh
 

Spectrum

macrumors 65816
Original poster
Mar 23, 2005
1,431
754
Never quite sure
Probably Flash

I was also suffering weird scroll bar atrifacts.

The disappearing pointer was only happening to one window - one with a flash advert at the top - I'm thinking that this was eating all the CPU power, even when not physically displayed on screen.

On getting to my computer this morning, safari had "unexpectedly quit".

Things seem fine. safari back to using 10-25% of CPU when at front.

I'm running...10.3.8
 

Spectrum

macrumors 65816
Original poster
Mar 23, 2005
1,431
754
Never quite sure
Tracked it down!

Ok it happens on this page:

http://www.kenrockwell.com/nikon/d70lens.htm#summary

because of the duck-shoot flash advert.

When you go into the duck-shoot the pointer changes to the target - fine and good when the advert is visible.

but when you scroll the page down so the ad is off the top. now when you go to the toolbar, the pointer disappears!

Can you disable these adverts?
 

Spectrum

macrumors 65816
Original poster
Mar 23, 2005
1,431
754
Never quite sure
Firefox...

Mitthrawnuruodo said:
That's an old bug. I think that's been happening in every version of Safari. (But I'm not sure since I used Firefox from Nov 2004 - May 2005. ;))
my only problem with Firefox is that new windows open my homepage, rather than cloning where you already are. I cannot find a way to change this.

AND

I use this feature A LOT.

Firefox is great for GoogleMaps though...