Strange iMessage Behaviour

Discussion in 'iOS 5 and earlier' started by Saberon, Oct 13, 2011.

  1. Saberon, Oct 13, 2011
    Last edited: Oct 13, 2011

    Saberon macrumors 6502a

    Joined:
    Sep 16, 2008
    #1
    Upgraded my iPhone 4 to iOS 5 yesterday but in Messages I have no option for an @ symbol so I can iMessage an email address. My friends 3GS does however. So I do a full restore/setup as new iPhone, now the @ symbol (and tons of other symbols) show up in iMessage. So I start typing my friends email address and it doesn't auto suggest. So I go to contacts, find the address, and tap send message. It shows their email address without the @ symbol in iMessage and my keyboard is all messed up again (no @ symbol and tons of other symbols missing)

    I'd have to restore just to get it to fix the darn keyboard again...anyone else seeing this? My friends 3GS works perfectly. I've tried iMessage on/off, soft/hard reboot and nothing fixes it except for a restore, which then gets broken when I attempt to text my friends email address.
     
  2. spblat macrumors 6502a

    spblat

    Joined:
    Jun 18, 2010
    #2
    That's weird indeed. No issues here. I'd call Apple tech support.
     
  3. xraydoc macrumors demi-god

    xraydoc

    Joined:
    Oct 9, 2005
    Location:
    192.168.1.1
    #3
    Is it only this one friend's email address? Perhaps his calendar entry is somehow corrupted which is causing the issue. Try restoring to get the keyboard back to normal but try either a different friend's email address or delete this friend's address book entry and redo it.
     
  4. Saberon thread starter macrumors 6502a

    Joined:
    Sep 16, 2008
    #4
    Wow I fixed it, but it was a strange fix.

    I always have Send as SMS turned off, and since that is turned off I also turned off MMS messaging below. I turn MMS messaging ON (even though send as SMS is still off) and my keyboard is 100% normal again and my friends email shows up in my contact and I can iMessage him.

    I turn MMS off and my keyboard goes back to missing all the symbols and I can't see my friends email under auto-suggest.
     
  5. RNVarma macrumors regular

    Joined:
    Feb 4, 2010
    #5
    Yup, same thing fixed my missing '@' on my keyboard. I'm on an off-contract GSM 4S with T-Mobile USA.
     

Share This Page