Strange iPhone Problem

Discussion in 'iPhone' started by lonman06, Mar 23, 2011.

  1. lonman06 macrumors regular

    Joined:
    Feb 23, 2010
    #1
    I have been having a weird problem with my iPhone. I usually charge my phone overnight and take it off the charge first thing in the morning. When I first got the phone about 2 weeks ago the battery would stay at 100% for about the first hour even when I used it a decent amount.

    2 weeks later if I just turn the phone on it drops 1 percent every 5 minutes or so. One day I decided to restart it after 15 minutes off use (battery was at 96%) and it was back at 100! Now everyday I have to do this same thing to prevent it from dropping so fast. Is this normal? I have the Verizon iPhone btw. Any help would be greatly appreciated.
     
  2. Stealthipad macrumors 68040

    Stealthipad

    Joined:
    Apr 30, 2010
    #2
    You need to turn off the % feature so you can just relax and enjoy your phone.:p
     
  3. AndrewR23 macrumors 68040

    Joined:
    Jun 24, 2010
    #3

    This, ive has mine off the last week now and i actually believe battery is better although i know its really not. or is it?
     
  4. JamesMB macrumors 68000

    JamesMB

    Joined:
    Jan 2, 2011
    Location:
    Texas
    #4
    How often do you cycle your battery?
     
  5. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #5
    Battery calibration, slight differences in use, and calculation of % can all effect this, your phone is fine, done worry about it.
     
  6. lonman06 thread starter macrumors regular

    Joined:
    Feb 23, 2010
    #6
    I'm still confused. Isn't that something to worry about since the battery is dropping so fast the phone would be dead in a few hours. Still not sure why I need to restart to get the battery back to normal.
     
  7. TigerBabe macrumors 6502

    Joined:
    Aug 6, 2010
    Location:
    Hollywood
    #7
    Did you do an update? The same thing happened to me after I updated to 4.3 so I did a restore and turned Ping off and now battery is back to being incredible again ;)!
     
  8. lonman06 thread starter macrumors regular

    Joined:
    Feb 23, 2010
    #8
    I am on the Verizon iPhone, so still on 4.2.6.
     

Share This Page