strange iPhoto problem

ero87

macrumors 65816
Original poster
Jan 17, 2006
1,196
1
New York City
Hey everybody,

So I just imported my summer photos from my Canon Powershot - the pictures imported like a dream (so i thought!). Now when I try to view/edit the photos fullscreen, I can only view the photos taken VERTICALLY. strange issue, right? any picture taken horizontally (i.e., normally) results in a large exclamation point.

Also, I tried importing some of these files manually into iPhoto and I got an error message. Anyone ever had similar problems? I'm really wierded out and I'd love a solution.

Thanks!
 

mad jew

Moderator emeritus
Apr 3, 2004
32,199
6
Adelaide, Australia
Just to confirm, this is only when editing in full screen, right? Do the pictures appear normally in the library and edit windows? Also, what did the error message say? :)
 

Abstract

macrumors Penryn
Dec 27, 2002
24,414
124
Location Location Location
Did you try to move the files from their folders, then manually move them back in?

You can't reimport photos if iPhoto thinks that the photo is already in it's library. Basically, I think that iPhoto won't let you reimport the photos because it thinks that you have already imported those exact same photos in before.
 

ero87

macrumors 65816
Original poster
Jan 17, 2006
1,196
1
New York City
two clarifications:

1. I deleted a photo from iPhoto then tried to re-import the original file, getting an error message. Would I get that with any photo, or are my files corrupted?

2. The files won't show up in fullscreen OR any iPhoto edit mode. It's very strange. The actual files work in Preview slideshow mode, and as a thumbnail in iPhoto...
 

ero87

macrumors 65816
Original poster
Jan 17, 2006
1,196
1
New York City
okay, so I fixed the problem by copying all of the original files, putting them in another folder, deleting them off of iPhoto and importing the copies.

still a strange problem...