Strange iPod Issue

Discussion in 'iPod touch' started by thesdx, Jul 5, 2008.

  1. thesdx macrumors 6502a

    Joined:
    Jul 12, 2007
    #1
    I just restored my iPod after the battery was showing an incorrect charge. Right after I restored it, I started to rearrange my icons. The jiggling froze, so I rebooted. When it booted back up, the Apple logo showed up with no backlight and then went to the "connect to iTunes" logo. When I connected, it asked me to restore. It stayed on "Preparing to restore" for a minute or two, and then threw up the error message below. I've tried all the known solutions, including downgrading the firmware, but nothing works. What should I do?
     

    Attached Files:

  2. davidy macrumors 6502

    davidy

    Joined:
    Jan 28, 2008
    #2
    If you tried all the known solutions and it didn't work, your only recourse is to take to the nearest Apple Store.
     
  3. djjoja macrumors member

    Joined:
    Mar 15, 2008
    #3
    Tried going into DFU Mode manually AND through iLiberty?
     
  4. dagored macrumors 65816

    Joined:
    Sep 18, 2007
    Location:
    Florida
    #4
    Turn on ipod --> Press and hold Home+Sleep (for very long) --> iPod goes to sleep --> Keep holding Home+Sleep --> iPod Wakes up again --> bang... The screen that ask you to plugin your ipod to itunes.
     
  5. thesdx thread starter macrumors 6502a

    Joined:
    Jul 12, 2007
    #5
    I've done that, and just about every other solution, but nothing works.

    EDIT: It seems to be working now. I managed to get it restored, though my battery is still extremely low. Hopefully, it doesn't do this to me again.
     
  6. dagored macrumors 65816

    Joined:
    Sep 18, 2007
    Location:
    Florida
    #6
    I should have told you it takes a couple tries sometime and now I would let it charge for at least 6-8 hours. If the battery dies then, take it back. It is still under warranty.
     

Share This Page