Strange issue when I try to delete an app..

Discussion in 'Jailbreaks and iOS Hacks' started by Astin, Jul 17, 2009.

  1. Astin macrumors regular

    Joined:
    May 26, 2009
    #1
    So I went to the app store to download the full version of a free game I have, as a promotion (iMobsters if anyone is familiar with it).

    Well when I went to the app store, it didn't respond at all when I selected to install it..

    And now, when I hold down my finger on an app to delete it (was going to delete the free version to see if it'll allow me to get the full version), rather than the icons starting to jiggle around and let me delete the app, the icons stay still, and the little red "X" appears to delete the app, but it's unresponsive.

    Has anybody else experienced this? Do I need to restore my iPhone?:(
     
  2. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #2
    Is your phone jailbroken? You should try syncing/deleting the app through iTunes if the App Store isn't playing nicely.
     
  3. Astin thread starter macrumors regular

    Joined:
    May 26, 2009
    #3
    Of course it is =P.

    Yeah I might have to.. Dang I knew I'd break something if I tinkered with it too much..
     
  4. jmann macrumors 604

    jmann

    Joined:
    Dec 8, 2007
    Location:
    bump on a log in a hole in the bottom of the sea
    #4
    Make sure that you don't have wigglefree installed. That might be messing with things.
     
  5. Astin thread starter macrumors regular

    Joined:
    May 26, 2009
    #5
    I don't have it installed, never even heard of it ;).
     
  6. The General macrumors 601

    Joined:
    Jul 7, 2006
  7. Astin thread starter macrumors regular

    Joined:
    May 26, 2009
    #7
    Yes, 3 times.
     
  8. The General macrumors 601

    Joined:
    Jul 7, 2006
    #8
    Time to restore, then. :(
     
  9. Astin thread starter macrumors regular

    Joined:
    May 26, 2009
    #9
    There is no "cry" emoticon.. Booohoooohooo.. I put so much time into this, not to mention all my Cydia apps, ugh. Will AppSync or something work to retain my apps through the restore process?
     
  10. miggitymac macrumors 6502a

    miggitymac

    Joined:
    Jan 7, 2009
    #10
    I had to restore last night too...

    iTunes will hold all your iTunes Store apps (legit or not) but will not sync the less-legit ones until you get AppSync.

    As for the Cydia apps, you'll have to reinstall those ones manually...but it really doesn't take that long if you already know what you need/want.

    My restore + re-customizing took only about 15 mins total.

    But yea...still sucks...

    Good luck
     
  11. Astin thread starter macrumors regular

    Joined:
    May 26, 2009
    #11
    So I found out the source of the problem:

    Popup Blocker

    The early beta release by David Ashman's repository.

    I removed it and now my apps jiggle and I can delete again, hooray!

    I installed it a few hours ago, and haven't dealt with the app store until the bug started happening, so thanks to backtracking, I saved myself hours of frustration restoring and rejailbreaking and reinstalling all my apps, hoorah!

    EDIT

    Lol, just to kick me in the balls, I can't even download the new iMobsters.. it is over 10MB and I'm at work with no wireless connection, will have to wait to get home, hehe.
     

Share This Page