Strange issue with audio cds

Discussion in 'macOS' started by matttrick, Jun 5, 2010.

  1. matttrick macrumors 6502

    Joined:
    Aug 28, 2006
    #1
    Data cd's cause no problems. I recently decided to rip some of my old cd's to itunes. The first one I put in copied the tracks, but when i pressed play it would skip to the last track every time and only play it.

    Now another CD is causing the system to virtually lock up once it is in. The first time i opened the disc and it only showed one track, track 32. I reinserted it and then it would not show at all. Then it took a minute for a browser to open. Took the disc out (it would only eject when i restarted and held eject while booting by the way) and everything is fine.

    Tried some others and similar issues are popping up. These are older discs, early 90s and on. They are not in bad shape and play fine in my ps3 and other drives. Ideas?
     
  2. matttrick thread starter macrumors 6502

    Joined:
    Aug 28, 2006
    #2
    to update a little more, this is on my intel imac running snow leopard. The drive shows up in system profiler under disc burning. No discs will mount, and the only time I can eject a CD is before the OS loads, either holding eject or using option to get startup disk selection. The disc never shows there, but I can eject without a problem.

    I tried a reinstall (not clean) and after that when i inserted a disc after os x loaded it said the disc could not be read. After that no eject, same problem. Subsequent discs just never showed up, not even the error. They all work in my mbp drive so its not the discs.

    Also the issue is no longer just with audio CDs. It is really confusing because at first they were loading but skipping songs, then just showing one track with a random number, and lastly showing nothing at all.

    I am torn between a clean install or a replacement drive. I have a lot of stuff on my imac and I doubt I could back it all up... and the thought of restarting my itunes library really is not one I am happy about. Could really use some suggestions.

    Oh also, I tried resetting the PMU and PRAM as suggested in the few topics i found on this issue, no effect.
     
  3. matttrick thread starter macrumors 6502

    Joined:
    Aug 28, 2006
  4. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #4
    You can't fix hardware with software.
     
  5. matttrick thread starter macrumors 6502

    Joined:
    Aug 28, 2006
    #5
    ok i really dont think it is hardware now. i used my MBP in target disk mode through firewire. i put a disc in there and the imac said the disc could not be read.

    booted the laptop normally and the discs read fine on there, it is only when the imac is looking at them that there is a problem? does this sound like an OS problem? ive read a little about similar issues but i cant seem to pin down a solution.
     
  6. matttrick thread starter macrumors 6502

    Joined:
    Aug 28, 2006
    #6
    till experiencing this issue, any suggestions besides a clean install?
     

Share This Page