Strange Issue With Booting Windows (works after cold boot but not restart)

Discussion in 'Mac Pro' started by robbier, Nov 2, 2011.

  1. robbier macrumors member

    Joined:
    Apr 27, 2008
    #1
    Hello,
    I am currently experiencing a very strange issue regarding booting into Windows. If I restart my Mac Pro, hold down the option key, and select my Windows partition, I get a black screen and the fans spin up. However, if I completely power down the machine and cold boot it, I am able to hold down the option key and select Windows and boot successfully. So, essentially, I am able to boot into Windows only after a cold boot, and not a restart due to the aforementioned problems. Although not particularly serious, I would like to fix the issue as it is pretty annoying.

    This same issue occurs even when trying to boot to the Windows 7 installation DVD, so I doubt it has anything to do with my Windows installation. I am guessing it has something to do with the BIOS emulation function of EFI and something about rebooting vs. cold booting, but I am not completely certain. Any help is appreciated.

    Thanks so much,
    robbier
     
  2. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #2
    What happens if you select Windows as the boot partition from within OS X and restart instead of restarting and selecting with the keyboard?
     
  3. robbier thread starter macrumors member

    Joined:
    Apr 27, 2008
    #3
    Thanks for the suggestion. I just tried that and got the same result. The computer rebooted and I got a black screen. I had to hold down the power button to manually shut off the computer, and after turning it on, it booted into Windows just fine.
     
  4. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #4
    PRAM reset:

    Boot Mac. Hold down the keys: Command Option P R. Release keys after the second chime.
     
  5. robbier thread starter macrumors member

    Joined:
    Apr 27, 2008
    #5
    I thought I would post a little update to this situation. I have been fairly busy over the past few months and haven't had much free time, but I just started working on this issue again a short while ago. I did reset the PRAM multiple times, and that didn't seem to help much. I tried installing a boot utility called "BootChamp," and I am having the same problem even when using that utility. I think I even tried repairing the disk as well as the disk permissions for both my Mac HDD and Windows 7 HDD, but, again, this booting issue didn't go away.

    I did call Applecare and they suggested reinstalling Windows 7 because, according to them, this is an issue with my particular Windows 7 installation. However, I have already ruled that out because I tried rebooting into the Windows 7 installation DVD (a known good copy of windows) and I still get this issue.

    Thanks again for any help!
     
  6. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #6
    I'm a complete amateur at this, but the next thing I'd suggest is testing all your memory.

    This is coincidentally identical to a problem I had many years ago rebooting from Red Hat to Windows. Windows would not load from a Red Hat reboot. It would only load from a cold start or a Windows reboot. In my case, switching video cards solved the symptom. I never found out what the actual problem was; the video card worked fine in all other aspects so I don't really think it was to blame.
     
  7. dreko macrumors newbie

    Joined:
    Dec 31, 2011
    #7
    This is what I do....

    I've also experienced the same problem

    I haven't found the EXACT cause but for me:

    I disconnect 1 firewire drive
    I start tapping/holding down the ESC key as soon as it reboots/or coldboots

    You'll get a black windows boot screen, I select win 7 os and proceed fine from there...

    good luck
     
  8. initialsBB macrumors 6502a

    Joined:
    Oct 18, 2010
    #8
    I have this weird problem when selecting the windows partition by keyboard and hitting the return key blocks the computer on the black screen. Turns out that using a wired USB mouse to select the windows partition and double clicking works every time...
     
  9. robbier thread starter macrumors member

    Joined:
    Apr 27, 2008
    #9
    Thanks for all the replies,
    I will try the mouse suggestion and escape key suggestion tonight. I did also test the memory using the Apple Hardware Test and it didn't find any issues, so I am not sure what is going on here.
     

Share This Page