Strange issue with Lumix/SD/Mac compatibility

Discussion in 'Digital Photography' started by msugarpants, Apr 26, 2008.

  1. msugarpants macrumors member

    Joined:
    Jan 4, 2005
    #1
    Ok, this one is weird, so bare with me. I have the panasonic DMC-TZ3. i LOVE this camera. it has been reliable and stellar for all my purposes. One day, after loading my usual gig on an SD card, my card reader would not read it on the mac anymore. it said the disk was not initialized. When i put it back in the camera, it showed i have all the pics. So, what is going on here? I always load from a card reader and there was never a prob. Now i loaded from 2 other SD cards, and none of them worked. Please help me understand how to remediate this situation so i can take pics, put them in my reader, and iphoto opens, just like the old days! any insight would be great. i am frustrated. maybe it is the reader? i do not have a cord to connect camera to computer directly.

    thanks
    mike:confused::apple:
     
  2. John T macrumors 68020

    John T

    Joined:
    Mar 18, 2006
    Location:
    UK.
    #2
    If, as you say, you've unsuccessfully tried reading from other cards, it sounds as if the reader is at fault. Any chance of gaining access to another reader in order to check?
     
  3. msugarpants thread starter macrumors member

    Joined:
    Jan 4, 2005
    #3
    thanks for the reply. Ok, the card reader works on the PC at work. So, it probably is not the card reader. However, i will buy a new one regardless. I just dont think that is it. it says the card must be initialized, so mac is seeing the card.....it just always read it before. and this is happening to all the SD cards i try. yet the pics appear on the camera. Hmmmm....ARG!!!:eek:
     

Share This Page