Strange keybord keys behaviour

Discussion in 'MacBook Pro' started by Galak, Jul 10, 2016.

  1. Galak macrumors newbie

    Joined:
    Jul 10, 2016
    #1
    Dear All,





    I have a MacBook Pro 13" MID 2012 (MacBookPro 9,2) running on 10.9.5 with 4 Gig of RAM.



    Recently the integrated mouse pad started to go crazy, possibly although not sure because of liquid. In the process it fried the Hard drive for some reason.



    So I opened it, cleaned the mouse pad in alcohol, put it back changed the HDD and it started working fine again. Unfortunately in the process the PAD go hit and cracked in the corner. It still worked, but didn't look nice. So, bought a new track pad and replaced it. It works perfectly fine. So all good on that side.



    But... something strange then happened, even before I replaced the pad. The keys F11, F12, Disk eject and backspace stopped working... All the other keys work perfectly. When I changed the track pad, they still didn't work, but after 5 minutes or so they suddenly worked again. I turned the computer off and when I turned it back on, they were not working anymore and never came back to life since. When I use the Keyboard viewer, they do not react either.



    Now here comes the very very strange bit. If I combine them, that is if I press them all at the same time, they do react... backspace+eject+F12 gives me the apostrophe and shows on the Keyborad viewer as such. eject+F12+F11 gives me the inverted commas and again shows as such on the Keyboard viewer. eject+F12+F11+eject gives me both the inverted commas and the apostrophe and again shows as such on the Keyboard viewer. If I try these combinations on a computer that doesn't have that problem, these combinations give nothing...



    Any other combination of these keys do not give anything. Also to test if each key was actually recognised, I pressed both combination varying which was the last key pressed, and they all seem to be picked up, which seems to indicate that they all work.



    I did a fresh install of Mavericks, nothing. I cleared the VRam, nothing.



    I tried to disconnect the mouse pad altogether and start the computer, and then to my surprise the whole keyboard is not recognised anymore, indicating that somehow keyboard and trackpad are related. When I connected it again, the keyboard worked but those 4 keys still not.



    Any ideas as to what I could do? I can live without the F and eject keys, but not having the backspace is really a pain.



    Thank you all !
     
  2. T5BRICK macrumors 604

    T5BRICK

    Joined:
    Aug 3, 2006
    Location:
    Oregon
    #2
    If you're saying the computer was involved in a liquid spill, that is most likely your problem.
     
  3. tubeexperience macrumors 68030

    Joined:
    Feb 17, 2016
    #3
    If after a liquid spill the keyboard doesn't work, then replace the keyboard.
     
  4. Galak thread starter macrumors newbie

    Joined:
    Jul 10, 2016
    #4
    Thanks guys,

    The keyboard works, besides those keys. Is it possible to pop the key off from the keyboard side, or you have to get from the inside?
     
  5. tubeexperience macrumors 68030

    Joined:
    Feb 17, 2016
    #5
    You have to remove the logic board and optical drive.
     

Share This Page