Strange letters or symbols coming up in browser auto populate

Discussion in 'OS X El Capitan (10.11)' started by bryada, Oct 11, 2015.

  1. bryada macrumors newbie

    bryada

    Joined:
    Sep 26, 2013
    Location:
    Inner Mongolia
    #1
    When using safari, chrome, firefox, whatever every so often I will start to get strange letters or symbols come up in the URL bar when attempting to do a search. I can never type in what I am looking for as it thinks I am trying to search in Swedish or Finnish or some language I don't speak. If I restart my computer (3 month old iMac) the problem goes away but it always ends up coming back later on in the day. I attached some sample pictures. In th first one I am trying to type Kolt and it wouldn't stop at the "t" and kept going with suggestions.
    IMG_5502.JPG IMG_5503.JPG IMG_5503.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG IMG_5502.JPG IMG_5503.JPG
     
  2. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #2
    "Strange letters".... You know, english isn't the only language in the world. The OS is just suggesting variations of the character you last wrote. Just stop holding down the button of the last character. Restarting your computer has no effect on it, only your fingers.

    And why did we need the same screenshots shown 20 times? o_O
     
  3. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #3
    Hi,

    if you don't need the "strange letters..." (I DO need them in my language) you can change this behavior :

    Open the Terminal (Applications/Utilities), paste this :

    Code:
     defaults write -g ApplePressAndHoldEnabled -bool false
    
    Now when you hold a key, it will repeat the same letter instead of suggesting variations of this letter.
     
  4. bryada thread starter macrumors newbie

    bryada

    Joined:
    Sep 26, 2013
    Location:
    Inner Mongolia
    #4
    Sorry to anyone I may have offended, they are strange to me as I have English as the default and have never enabled any other languages on my computers. Could it be an issue with the keyboard as I am not holding any keys down just typing.
     
  5. interstella macrumors regular

    interstella

    Joined:
    Sep 29, 2013
    Location:
    Suffolk, England
    #5
    I'm having the same problem occasionally and I can't work out what's causing it. When it happens I can't use Safari at all. Any keyboard inputs result in a series of quiet but rapid "beep" (click?) noises and the only option is to force quit Safari.

    This has only started since installing El Capitan.
     
  6. eneisch macrumors 6502a

    Joined:
    Jul 11, 2008
    #6
    I have the same issue. I think it is related to the bluetooth keyboard lag on wake from sleep that has been reported bu other users. It thinks you are holding doesn't a key, but you are not. Started happening to me since I installed El Capitan too.
     

Share This Page