strange mission control full screen behavior

Discussion in 'macOS Sierra (10.12)' started by ragnu, Nov 1, 2016.

  1. ragnu macrumors member

    Joined:
    Mar 15, 2015
    #1
    This isn't actually a Sierra issue, since I think it occurred in earlier versions as well.

    Say I've got three different Power Point presentations open, each in full screen, thus on its own desktop. Now, say I'm on my main desktop, with another application than Power Point active, and I want to go to a specific PP document. I invoke Mission Control, click on the document/desktop I want, I get taken momentarily to the right desktop, but then it usually immediately changes to another desktop and I have to invoke Mission Control again to choose the right one. However, if I'm already in Power Point, the problem doesn't exist. I find this behaviour weird. Any help?
     
  2. cincygolfgrrl macrumors 6502

    cincygolfgrrl

    Joined:
    Apr 2, 2012
    Location:
    Somewhere In Time
    #2
    When on a PP desktop, will CMD + Tilde (~) scroll you through other open PP presentations? Doing that works for me on the same desktop scrolling through multiple Excel spreadsheets, but don't know if it works for multiple desktops.
     
  3. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #3
    Haven't tested this but try changing the "When switching to an application, switch to a Space..." option in System Preferences > Mission Control. See if that affects the behavior.
     
  4. ragnu thread starter macrumors member

    Joined:
    Mar 15, 2015
    #4
    Yes, I tried that, to no avail. It's as though, when I'm in Safari, say, on desktop 1 and use Mission Control to go to desktop 4 (i.e., the third desktop with a full-screen PP presentation), my computer thinks I'm simply switching apps and goes to the first PP document rather than the one I chose. Anyway, I thought it may be a Microsoft-related problem, so I created three TextEdit documents, named 1, 2 and 3, put them on separate desktops, and indeed the problem didn't occur.
     

Share This Page