Strange New Mail Bug?

Adult80HD

macrumors 6502
Original poster
Nov 19, 2019
424
457
I'm curious if anyone else has seen this. This is a new development for me but poking around over on the Apple support forums I've seen one or two other reports of this.

About two days ago Mail suddenly stopped syncing regularly with my hosted MS Exchange through Office 365. What's weird is that the account setup shows it's fine and connected, and I can send mail with no problem. The inbox just doesn't update to show new messages except at random intervals. Interestingly enough, other folders will do the same thing--sometimes the Trash folder will update or the Junk folder, while the Inbox remains out of sync.

I thought it was a 10.15.6 Beta problem, or something with my account. I have tried deleting the account and totally recreating it. It syncs once, then it stops. Today one of my employees reported the same problem, and they are of course using their own email account on the same server, but the iMac they are using is on 10.15.5.

If I use Outlook, everything works fine, but I dislike Outlook--a lot. It's all fine on everyone's iPhones, too, so it seems like it's not a server issue on the Microsoft side, but something odd with Mail itself.

Is anyone else using Exchange and experiencing anything like this?
 

Zach_

macrumors newbie
Jun 12, 2020
2
0
My Macs stopped syncing with Office 365 today at about 1:45pm. I've since deleted the internet account from two systems and re-added them, but that hasn't helped. FYIW, I'm running 10.14.5.

In Mail's Connection Doctor, enabling the logs creates a log file for account "(null)" and the file size is zero bytes.

Something is severely broken with either iCloud or Office 365.
 

Adult80HD

macrumors 6502
Original poster
Nov 19, 2019
424
457
My Macs stopped syncing with Office 365 today at about 1:45pm. I've since deleted the internet account from two systems and re-added them, but that hasn't helped. FYIW, I'm running 10.14.5.

In Mail's Connection Doctor, enabling the logs creates a log file for account "(null)" and the file size is zero bytes.

Something is severely broken with either iCloud or Office 365.
OK so I started seeing it yesterday afternoon some time. If I rebuild the inbox, it updates, but then it immediately goes back to not updating at all.
 

Taz Mangus

macrumors 601
Mar 10, 2011
4,824
949
OK so I started seeing it yesterday afternoon some time. If I rebuild the inbox, it updates, but then it immediately goes back to not updating at all.
I would suggest try creating a new clean user account and setup the e-mail in the new used account. See if the issue still happens in the new user account.
 

Adult80HD

macrumors 6502
Original poster
Nov 19, 2019
424
457
Interesting update: Last night I did a rebuild of the mailbox. The mail all came in and I thought I had it solved...but then it stopped syncing. I could make it sync by repeatedly doing mailbox rebuilds, but it wouldn't sync on its own.

This morning, everything is working perfectly. I've had both Outlook and Mail open and they are both remaining in sync. Either MS had a problem that only effected Mac Mail users or Apple had some issue (although I can't see how?), but it *appears* to be resolved.
 

Wayne Vineyard

macrumors newbie
Oct 16, 2020
1
0
Well, this problem seems to have cropped up again with Outlook 16.42. I am running Mac Mail on Catalina with no problems for months then the Outlook updated and my Mac Mail Inbox won't synchronize. All the other folders; like Sent or Trash, update just fine. If I delete my Exchange account and then add it again, I get any new emails. But nothing will synchronize after that.

Anyone else seeing this crop up again?
 

leonchu1225

macrumors newbie
Oct 15, 2020
2
0
Same thing happened to me this week. I was guessing it could be the update of macOS 10.15.7 did this. As I knew I updated this version about a week ago, but can't be sure.
Didn't notice the update of Outlook. I wasn't using it, but did install it when I installed Office365 years ago.

Nothing worked for me. Apple Support was helpless. Asked me to grab bunch of data and just asked another rep to call me back. Check the Connection Doctor I checked 100 times and told me it's 365 server issue.

Tried rebuild the mailbox. Download kept stopped itself and I had to restart Mail multiple times. I have about 30,000 emails over the years and it took me 3+ days to get everything done...yet the issue is still there.

I also read an old Apple support link claim the Exchange mailbox can't go over 10,000 messages, but I don't think that's the issue, as my Mail was all ok before this week. Still, I moved a lot of those 30,000 emails to Archive (with Outlook as it's more stable and reliable atm) and now re-downloading those emails again.

iOS mail. Outlook on Mac (now I have to check the email with this. Still don't like it, but at least it's reliable so far). Spark on Mac all ok. Gmail and other accounts all good.
Tried everything I could find online (thus see this post) and nothing worked so far.
My guess was the Mail issue (due to the upgrade), O365 server issue (they changed something on their end and Mail stopped working).

The only thing that is remotely helpful is the click Shift when opening Mail. It goes into Safe mode according to Apple Support (not much diff I can notice compare to normal mode) and the download/sync is slightly more reliable. Still not normal though.

I guess I would have to hoping Big Sur would fix it or it's O365 server issue and they fix there.
Any suggestions would be appreciated!
 
Last edited:

gogogut

macrumors member
Aug 6, 2012
61
3
I am having this problem with Mac Mail connected to a work gmail account. Everything works fine if I login to the gmail account in a web browser. I see and can interact with all my messages. But the Mail app has serious sync issues for a couple days now. For hours it tells me I have no email, so I quit and start back up to see lots of missed emails. Then when I try to view them, I get Loading with the spinning gray circle. Sometimes the emails appear after some time, but it is nearly impossible to read and interact with email. If I compose a message and send it, there is no problem. I need a fix ASAP!
 

leonchu1225

macrumors newbie
Oct 15, 2020
2
0
I am having this problem with Mac Mail connected to a work gmail account. Everything works fine if I login to the gmail account in a web browser. I see and can interact with all my messages. But the Mail app has serious sync issues for a couple days now. For hours it tells me I have no email, so I quit and start back up to see lots of missed emails. Then when I try to view them, I get Loading with the spinning gray circle. Sometimes the emails appear after some time, but it is nearly impossible to read and interact with email. If I compose a message and send it, there is no problem. I need a fix ASAP!
I have 2 gmail accounts and both of them are all normal. Not sure if your work gmail account has any special setting on the server side. My work O365 account also is fine with sending email. Just don't pull in the email so I miss many work emails (that's terrible). Hopefully we get a fix soon.
 

vett93

macrumors regular
Jul 27, 2014
108
7
California
I have similar problems with Yahoo mail messages. I have 5 email accounts on my Mac Mail. The problem only exists with Yahoo mail. Mac Mail would work for a day and then stop retrieving messages from my Yahoo account. If I quit Mac Mail and start it up again, it would work another day and stop again. I can retrieve Yahoo mail using web reliably. I have contacted Apple and Yahoo support and cannot resolve the problem. The problem seemed to start 6 months ago and it worked fine before that.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.