Strange permissions problem on external hardrive

Discussion in 'Mac Basics and Help' started by markfrancombe, Feb 25, 2017.

  1. markfrancombe macrumors newbie

    markfrancombe

    Joined:
    Feb 25, 2017
    #1
    Hi,
    I have a 1TB LaCie external hard-drive. I want to transfer a smallish Premier project from my laptop to my main desktop computer, that is ElCapitan 10.11.6.

    First I plugged the external drive into my laptop and coped the project folder over, no problem.
    Then I connected the drive to my desktop, and decided to work FROM that drive, instead of copying it to my desktop iMac.
    First I got a warning that the scratch disks were incorrect for the project, this is expected as the project would have had a default location on the laptop, and premier offers to create on on the iMac, I select ok.
    But then I get a less understandable error. Cannot write to drive as I do not have permissions -50
    This is weird as 1. I JUST copied stuff to it on the laptop, and 2. I checked INFO on the disk and its as it should be read/write, but also as ignore permissions for this disk ticked.
    I then tried to run disk utility on it, expecting to be able to fix permissions that way. However (and I dont know how that has happen, bloody Apple, it has changed, and I only have First Aid as an option, I tried this, it was over in a second, but not fixed.
    FYI the disk is formatted as mac journalled...
    Right now Im backing up this disk to another 605,000 itmes (6 hours)... sigh... there goes THAT day...

    Any ideas?

    Mark
     
  2. chscag macrumors 68000

    Joined:
    Feb 17, 2008
    Location:
    Fort Worth, Texas
    #2
    No idea why the LaCie decided to deny write permissions. As you found out the version of Disk Utility for El Capitan (and Sierra) is brain damaged. Suggest downloading the free OnyX program which still has the "repair permissions" option among others that can be selected. Make sure you download the version of OnyX for El Capitan and not Sierra.
     
  3. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #3
    The repair permissions feature of pre-El Capitan Disk Utility only changes permissions on files that have a receipt in /var/db/receipts. Files you create would not be affected.
     
  4. markfrancombe thread starter macrumors newbie

    markfrancombe

    Joined:
    Feb 25, 2017
    #4
    Thx for your replies @chscag ... so.. we dont have a fix yet...
    looking at OnxX and Ill give it a bash when the back-up is done.. (2 hours remaining ... grrr)
    maybe @bcave098 means that it wont help... but Ill try anything... maybe throwing this disk away and buying a new one will work?
    :)
     
  5. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #5
    Open Terminal. Replace "NAME" in the code below with the volume name you wish to verify/repair before executing the command in Terminal. Maintain all spacing; if you don't copy and paste them, the commands start at the letter s in sudo and end with the letter E in NAME.


    To verify:
    Code:
    sudo /usr/libexec/repair_packages --verify --standard-pkgs --volume /NAME
    To repair:
    Code:
    sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume /NAME
    http://osxdaily.com/2015/11/04/verify-repair-permissions-mac-os-x/
    --- Post Merged, Feb 25, 2017 ---
    Forgot to mention, after you execute the command by pressing enter, you'll be asked for your admin password. Type it, you won't see it print on your display, then press enter again.
     
  6. markfrancombe thread starter macrumors newbie

    markfrancombe

    Joined:
    Feb 25, 2017
    #6
    Tried the verify above, got.. I simple typed the name of the disk, as I see it in Finder

    No packages can be found for this disk.

    topsecret:~ markfrancombe$

    i wonder what THAT means?
     
  7. rshrugged macrumors 6502a

    Joined:
    Oct 11, 2015
    #7
    I'm not sure. (As always make sure you have a backup of the drive.)
    Unless -- With the drive mounted, when you ran the command, you used the drive name rather than the volume name to replace NAME. In the image below, Untitled is the volume name. Generic USB Disk... is the drive. (Ignore the red arrows and partition instruction. I uploaded the image only to give a visual of drive vs volume.)
    [​IMG]
     
  8. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #8
    OP:

    Try this -- it's an easy procedure and costs nothing.

    1. Connect the external drive (with the project on it) to the desktop
    2. Allow the drive icon to appear on the desktop, but DO NOTHING ELSE YET
    3. Click ONE TIME on the drive icon to select it
    4. Type "command-i" (eye) to bring up the "get info" box.
    5. Toward the bottom of the box, there is a "sharing and permissions" area. If it is not visible, click the "disclosure arrow" to reveal it.
    6. Click the lock icon and enter your password
    7. There should also be a checkbox "ignore ownership on this volume". Put a check into it.
    8. Close the get info box.

    NOW try to "copy over" the files in question, and open them on your desktop.

    Does this make any difference?
    Try it and get back to us.
     
  9. bcave098 macrumors 6502

    bcave098

    Joined:
    Sep 6, 2015
    Location:
    Northern British Columbia
    #9
    Probably because nothing on the disk has a receipt in /var/db/receipts
     
  10. markfrancombe thread starter macrumors newbie

    markfrancombe

    Joined:
    Feb 25, 2017
    #10
    In original post i said:
    2. I checked INFO on the disk and its as it should be read/write, but also as ignore permissions for this disk ticked.

    Kinda badly written, so i forgive you for missing that... but I have tried it...
     
  11. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #11
    The following consists of multiple steps. Please do each one, in order. If there's a problem with one, post the exact result here (including any error message) before proceeding.


    1. Using the Finder, can you create a new folder on the external drive?
    If so, then the drive itself doesn't have a permissions problem, but the destination where you're trying to copy the files does.
    If you can't create a new folder using the Finder, perform steps 2 & 3, posting the results here.


    2. Copy and paste this exact command into a Terminal window, then press the RETURN key:
    Code:
    mount
    The output will contain multiple lines. One line will have the name of the external drive.

    Copy and paste the complete line for the external drive into a post here (drag-select in the Terminal window, then ⌘C to get text on clipboard). Other output lines can be omitted, but the line naming the external drive must be complete and unaltered.

    Example of selected output from my computer:
    Code:
    /dev/disk0s5 on /Volumes/Work (hfs, local, journaled)
    /dev/disk4s2 on /Volumes/USB3_64 (hfs, local, nodev, nosuid, journaled, noowners)
    

    3. Copy and paste this exact command into a Terminal window, then press the RETURN key:
    Code:
    ls -led@ /Volumes/*
    The output will consist of one line for each mounted volume, followed by zero or more lines listing the extended attributes and the ACLs for each volume.

    Here's an example of selected output from my computer:
    Code:
    drwxrwxr-x@ 18 chown33  chown33   680 Feb 20 12:47 /Volumes/USB3_64
        com.apple.FinderInfo      32
     0: group:everyone deny delete
    drwxrwxrwx@ 35 root    admin   1258 Jan 15 12:48 /Volumes/Work
        com.apple.FinderInfo      32
    
    The removable USB stick "USB3_64" has a FinderInfo extended attribute, and an ACL entry that restricts deletion. The volume "Work" only has FinderInfo, no ACLs.
     

Share This Page