Strange problem with my AppleTV and Netflix

Discussion in 'Apple TV and Home Theater' started by k1ckdapro, Jan 13, 2016.

  1. k1ckdapro macrumors member

    Joined:
    Sep 28, 2014
    #1
    Hi,

    So I have the latest apple tv and while watching Netflix series, I always have to re-enable subtitles (on the same series), as if my Apple TV would be losing this setting... On my chromecast, the subtitles don't need to be reset each time.

    Did anyone experience something similar ? Any solution? Thanks in advance
     
  2. bheathain macrumors member

    Joined:
    Oct 5, 2015
    #2
    Are you reenabling via the Netflix app itself? If so, check the main ATV settings. There's a place to default CC to on and set the style. This would work in other apps too like Hulu (may not be intended).
     
  3. 2010mini macrumors 68040

    Joined:
    Jun 19, 2013
    #3
    OP

    Could possible be that someone whom you share your account with turns it off when they are using it. I had that problem
     
  4. k1ckdapro thread starter macrumors member

    Joined:
    Sep 28, 2014
    #4
    Hi, thanks for your input.
    My apple tv setting is set to German subtitles, the ones I need to reset every time.

    I just realized that I even needed to reactivate them after watching a single episode on my apple tv as soon as the following episode started (without turning it off)... Very strange.

    Also, nobody else is watching on my account...
     
  5. MrTazz macrumors member

    MrTazz

    Joined:
    Sep 23, 2015
    #5
    Same here I have to tell siri to turn subtitles on every time I watch something on Netflix
    Can't find any setting within Netflix, all I have is Sign out option
     

Share This Page