Strange problem with NTFS-3G driver

Discussion in 'macOS' started by Hurley811, Jul 29, 2009.

  1. Hurley811 macrumors newbie

    Joined:
    Jul 29, 2009
    #1
    Hey I read this forum a lot, but this is my first time actually posting. I am having a weird thing happen with the standard NTFS-3G driver to read and write on my external USB NTFS hard disk. I was hoping someone with a good understanding of drive formatting could help me out.

    To start with, I have two partitions on this drive mounted as V:/ and S:/. They are both NTFS with 4KB cluster size made in Windows XP. . I installed this driver and its syspref plugin from http://www.ntfs-3g.org/. It worked fine at first. I was copying files over files from my OS X disk to V:/ when Finder froze. I wasn't doing anything unusual - I think iChat and Mail were open. The system locked up and the mouse was beach-balling.

    I waited about two minutes before I deemed it "frozen." I used cmd+alt+esc to relaunch Finder. Then, I unplugged the USB from my computer. I noticed that V:/ was still showing up on the desktop. I tried to eject V:/, but it didn't go away. So I restarted my computer and it went away. At that point, I plugged in the HD to continue working.

    When I got back onto the V:/, I noticed a couple things wrong. Only two files on the root directory appeared. Also, I no longer was able to write to the disk. Under Info, it showed the proper 381GB used, but I had no way of accessing them. The S:/ still had write-access.

    Disk Utility listed V:/ as NTFS and S:/ as NTFS-3G. In the syspref plugin, only the S:/ was listed under "Mounted NTFS-3G Volumes."

    I tried reinstalling the driver, but it did not help. I consider myself computer-savy, but I don't know that much about drives. I am thinking that I might have partition's settings or such, so I was wondering if anyone knows how to recover the data. Has anyone else had this problem before? Is there a quick, FREE fix?
     
  2. Hurley811 thread starter macrumors newbie

    Joined:
    Jul 29, 2009
    #2
    Its a brand new MacBook Pro 15" 3.06GHz running Leopard

    Thanks for the help
     
  3. gatepc macrumors 6502

    gatepc

    Joined:
    Apr 11, 2008
    Location:
    Pittsburgh PA
    #3
    It sounds to me like you corrupted the partition table information. you can try repairing the disk but if that does not work I would try to recover all the data back it up and then reformat it. If you have to recover data then data rescue II is probably the best out there though it is not free.
     

Share This Page