Strange problem with streaming movies on iPad 2

Discussion in 'iPad' started by hafr, Nov 26, 2011.

  1. hafr macrumors 68030

    Joined:
    Sep 21, 2011
    #1
    I have an iPad 2 and a bunch of movies in my iTunes library that I want to watch using Home Sharing, but some of them are acting up. It seemed to be very random, so I decided to try to figure out the common denominator using MediaInfo and trying the films one by one.

    I figured out that movies over 2 GB with subtitles (1.83 GB works, 2.4 GB doesn't) are unwatchable when streaming to the iPad 2 or iPod Touch (bought this summer, 4th gen?). It has nothing to do with bitrate, as I can watch a 4 GB movie at 6 Mbps without subtitles with no problem what so ever, but a 2.4 GB movie at 2 Mbps with subtitles is a no-go.

    If I transfer the movie to the iPad it plays without any hick-ups.

    This is more than a little annoying, since most of the movies I have are with subtitles, but I almost never use them and I really don't want to have to go to the computer and transfer the movie to the iPad every time I want to watch one of these movies. The only solution I can come up with is to pull the movies through Handbrake to make them smaller and thus streamable, but I really shouldn't have to since it's such a freak problem that I can't stream films over 2 GB if they have subtitles...

    Is this a known problem, does anyone know about it, or is it just me? Can someone try it? Does anyone have a solution?

    Is it possible to extract the subtitles from a .m4v file? In that case, I can just use XBMC instead of the native player when I need subtitles when I'm watching the films on the ATV2, and can stream the films to my iPad...
     
  2. hafr thread starter macrumors 68030

    Joined:
    Sep 21, 2011
    #2
    I found a program called iSubtitle that is super easy to use for extracting and removing subtitles from films (but it's probably meant to be used to add subtitles ;)). So no more tears.

    But I still think it's very strange that I can't stream large films with soft subtitles. Does anyone else have this issue? Or can you try it and let me know if I'm experiencing a freak problem?
     
  3. hafr thread starter macrumors 68030

    Joined:
    Sep 21, 2011
    #3
    What, is no one streaming large films with subtitles to their iPads? :)
     
  4. Capt T macrumors 6502a

    Joined:
    Mar 20, 2010
    #4
    What is the audio bit rate set at for the movies? Some of the movies/video that i have 2 audio tracks for I have to choose the correct one when streaming, but it will be automatic if it is on the iPad.

    Have had no subtitle issues for the ones that have them as of yet.
     
  5. hafr thread starter macrumors 68030

    Joined:
    Sep 21, 2011
    #5
    There was no connection between audio bit rate or audio tracks amongst the movies that didn't work, it was just subtitles+over 2 GB file size. Removing the subtitles from a movie made it stream flawlessly, but streaming the copy with subtitles was near impossible.

    Then the strangest thing happened yesterday, my girlfriend streamed one of the movies that didn't work - and now it works. I've tried it with a handful of the films that didn't work, and they all work now... And I've done nothing to fix it that I hadn't already done before giving up.

    I guess iTunes was just being moody or something for a couple of days...
     

Share This Page