Strange problems -fixable or OSX reinstall?

Discussion in 'macOS' started by macstatic, May 6, 2013.

  1. macstatic macrumors 6502a

    Joined:
    Oct 21, 2005
    #1
    I've got several OSX related problems which I can't figure out. I'm running OSX 10.6.8 on a Mac Pro 5.1 with multiple internal drives where the apps, OSX and administrator user area is located on an SSD, and a separate drive contains my regular user area along with my files.

    Time Machine was getting very unresponsive/slow, so I eventually decided to delete the "Backups.backupd" folder (using rm -rf in the terminal IIRC). The backup drive contains other files/folders as well, which is why I didn't simply reformat the drive and start backing up again.
    Backing up from scratch took forever, but almost 24 hours for around 1TB is a bit much, isn't it (internal SATA hard drive connected to the Mac Pro main board)?

    The other thing is that I can't empty my trash can. OSX tells me that "Verdana.ttf" is in use, and not just once, but I get the same error message repeated the next time I press "Continue" -around 10 times in total. Neither logging out, rebooting or powering down helps.

    Finally, booting into safe mode (holding SHIFT while booting) takes forever (as in more than 5 minutes), so I finally had to press and hold the power button and start normally (which strangely enough worked fine). Disk utility takes a very long time to check the SSD (I booted from another drive) but eventually told me it was fine. Permissions seemed a bit off, but having learnt from another thread here the whole thing is a mystery as you get "error" messages even though nothing's wrong...
    I also tried running Applejack to check/fix the drive while booting into safe command-line mode (CMD-S while booting), but I'm still not able to empty my trash and do a normal Time Machine backup. Resetting the PRAM (ALt-CMD-P-R while booting) has also been tried without any different result.

    I do take regular backups and even have a dedicated drive just for cloning the system drive. Alas I've somehow messed up the settings in Chronosync and gotten some errors when backing up, so I wouldn't completely trust that backup (even though it boots just fine).

    So.... what do I do? I have no problem reinstalling OSX and my apps from a newly reformatted SSD, but I'm more concerned about the many settings and support files which I have a hard time keeping track of. So should I do that regardless or are there other things I could try first?
     
  2. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #2
    Update: I solved the trash can problem by rebooting with the cloned system drive in safe mode (holding down SHIFT while booting) which allowed me to empty it :) That simple :eek:
    Why did it happen in the first place though? A symptom of more serious issues on my drive(s) perhaps?
     
  3. crjackson2134 macrumors 68020

    crjackson2134

    Joined:
    Mar 6, 2013
    Location:
    Charlotte, NC
    #3
    It looks like you accidentally marked the Verdana system font for deletion. Since it's used by the system, you had several processes calling on it, preventing its complete removal. When you booted to a separate system, the file wasn't locked by other processes, thus allowing you to finish.

    Hopefully the font wasn't completely removed..
     
  4. macstatic thread starter macrumors 6502a

    Joined:
    Oct 21, 2005
    #4
    Hmmmm...
    I have a feeling I have to reinstall OSX and my apps to get it right again :(
     

Share This Page