Strange reboot/login behavior with FileVault2

Discussion in 'OS X Mountain Lion (10.8)' started by macmin, Dec 12, 2012.

  1. macmin macrumors newbie

    Nov 29, 2012
    I am wondering if anyone can help with a really strange behavior using FileVault2 FDE. I am on a late 2012 mac mini (middle model), added SSD, 16GB ram.

    With FileVault on the boot SSD enabled, when I restart, I get to the disk unlock screen. However, when I click on my user to unlock, it seems to automatically be typing in the password box! My bluetooth keyboards keystrokes go in there too, but obviously it doesn't work since somehow there are keystrokes in there already. The "automatic" keystrokes appear really fast, and continuously! I.e. I cannot just backspace and type my password in. If I shut it down and come back to it in a hour, everything is fine! Huh?

    I have already tried disabling all bluetooth and using a wired keyboard. Same.
    Moved my thunderbolt array to be as far from mini as cable will allow. Same.
    I disabled file vault, and the problem goes away.
    I reenable file vault, and problem is back.

    Ghost in the :)
  2. Weaselboy Moderator


    Staff Member

    Jan 23, 2005
    I use FV2 on my Macbook Air with an external Apple BT KB and have never seen anything like that. It does sound like something to do with the BT KB though. What brand KB is it? Do you have an old USB KB you can try to see if that makes the problem go away maybe?
  3. macmin thread starter macrumors newbie

    Nov 29, 2012
    I have the apple BT keyboard, but like I mentioned, I turned it off (removed batteries) and tried with a wired keyboard, to the same effect. I even moved my thunderbolt array to be as far away as possible, since OWC is now reporting the the mini's bluetooth receivers can suffer from interference from external drives. I may have to try their shielding....

Share This Page