Strange slowdown copying files

Discussion in 'iMac' started by ScottR, May 8, 2013.

  1. ScottR, May 8, 2013
    Last edited: May 8, 2013

    ScottR macrumors member

    Joined:
    May 11, 2007
    #1
    I have a 4 TB external G-Tech Raid FireWire 800 drive which has, all of a sudden, become very slow, though read times seem to remain quick. It doesn't matter if I'm copying to it from my internal drive or from an external. The problem drive is not the boot drive.

    A 100 MB folder with 65 items takes 1 minute, 10 seconds to copy (after a 6 minute initial estimate); a single 524 MB file takes 2.5 minutes (again, after a 6 minute estimate).

    What I've tried: booting from a different external drive, to be sure there's not some OS weirdness (I booted from both a flash drive and another external drive, both attached via USB). No difference. I've tried swapping cables; no difference. I've used the drive both daisy-chained and hooked up by itself (no other FireWire devices); no difference. The 4TB drive also has a mini-USB port; using that makes no difference.

    The other external FireWire 800 drives I have seem to work at normal speeds; I've done the same write tests with several drives.

    I've run both DiskWarrior and Disk Utility on the drive; they report no problems. Permissions were also repaired.

    Now, sounds like failing drive hardware, but....

    If I hook the drive up to my old PowerMac G5, it flies. That same 524 MB file I mention above takes about 5 or so seconds to write.

    What's going on?

    Mac is a 2.93 GHz iMac i7
     
  2. joe-h2o macrumors 6502a

    Joined:
    Jun 24, 2012
    #2
    Is spotlight indexing the drive on the new Mac?
     
  3. ScottR thread starter macrumors member

    Joined:
    May 11, 2007
    #3
    That drive is excluded. And no Spotlight activity is shown in Activity Monitor. The iMac it's running slowly on isn't new; the drive has been running on it just fine for a few years.
     

Share This Page