Strange thermal management issue

Discussion in 'MacBook Pro' started by Goettel, Oct 2, 2011.

  1. Goettel macrumors member

    Joined:
    Oct 1, 2008
    #1
    I've got a strange thermal management issue with my late 2008 MBP with 10.6.8. Usually my mac runs at around 40-48°C under normal workload (safari with click to flash, mail, ical, word, preview, skype) with a full charge estimated at around 4:30 use which is reasonable. A few weeks back, I noticed that my average temps had went up to 55-60°C range with the same workload. Even if I closed all my apps, temps would still be around 55° with 2:10 battery estimate... I tried a SMC reset which took care of the problem for maybe 2 weeks.

    Then this week the temps shot back up again. I noticed the process hidd using 1-3% processor (on and off kind of thing), killing it brings it back to 0% but temps stay high) A reboot tends to take care of the problem for a random time span. It seems as if the system's power management crashes at random moments. It is quite annoying as I have multiple files open on my mac and don't always want to reboot to get back half my battery life... Console (system.log) shows a lot of theses entries...

    Code:
    com.apple.powermanagement.applicationresponse.slowresponse 1374 ms
    Oct  1 08:26:49 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 1377 ms
    Oct  1 23:32:02 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection mDNSResponder com.apple.powermanagement.applicationresponse.slowresponse 116 ms
    Oct  1 23:32:02 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 925 ms
    Oct  1 23:32:02 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 927 ms
    Oct  2 09:28:01 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 992 ms
    Oct  2 09:28:01 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 994 ms
    Oct  2 15:15:14 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 1471 ms
    Oct  2 15:15:14 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 1472 ms
    Oct  2 18:12:54 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection AirPort configd plug-in com.apple.powermanagement.applicationresponse.slowresponse 1253 ms
    Oct  2 18:12:54 Nicolas-Goettels-MacBook-Pro configd[15]: PMConnection IPConfiguration com.apple.powermanagement.applicationresponse.slowresponse 1281 ms
    Any ideas on how to fix this?
     
  2. Goettel thread starter macrumors member

    Joined:
    Oct 1, 2008
    #2
    Trashed com.apple.powermanagement.plist from Library, upon reboot temps were still high (55-60°C idle, 2h battery)

    Did an SMC and PRAM reset and now back to normal (37-45°C idle, 4:45 battery)

    Lets see how long it will last this time...

    Tried booting off Lion on an external drive before doing the smc/pram reset and the temps were high under lion alors... could this be a hardware problem? Should I redo the smc and firmware updates?:confused:
     

Share This Page